iOS Question Mac Builder with Windows VM


Licensed User
Good day all,

I've read all of the posts about running b4i in a VM in my mac, but I can't seem to solve this last issue.

So i have Mac OS running the builder (Primary OS on a Mac PC)

And Windows running on Parallels (Network set to shared network) both has internet access:

I can run b4i and deploy to the mac builder, I can even access the mac builder site on my Iphone.

But when I click the install App button, i get an error saying "Cannot connect to" and the whole process stops there.

So i guess my question is,
What cannot connect to Is the app trying to connect to b4i on windows with the wrong ip? Or is it install related as the installation never even starts :/ Maybe some IP gets mixed up?

For some reason, when I deploy from my other windows only laptop, everything works.

Thanks in advance


Licensed User
Thank you Earl, the process does work when using remote Builder. I switched back to the local builder and I still get the "cannot connect to" when clicking on Install App.
Upvote 0


Licensed User
I just got home and connected to the home network (so my mac has a new IP) but i am experiencing the same issue.

mac ip:
windows VM ip (Still the same) :

Build server version: 2.51
2017-01-10 16:01:39.053:INFO::main: Logging initialized @150ms
Loading default configuration file.
Forcing ip address to:
2017-01-10 16:01:39.171:INFO:oejs.Server:main: jetty-9.3.z-SNAPSHOT
2017-01-10 16:01:39.217:INFO:oejsh.ContextHandler:main: Started o.e.j.s.ServletContextHandler@d041cf{/,file:///Users/schalkgreyling/Documents/macserver_25/www,AVAILABLE}
2017-01-10 16:01:39.219:INFO:oejs.AbstractNCSARequestLog:main: Opened /Users/schalkgreyling/Documents/macserver_25/logs/b4j-2017_01_10.request.log
2017-01-10 16:01:39.248:INFO:oejs.ServerConnector:main: Started ServerConnector@5b464ce8{HTTP/1.1,[http/1.1]}{}
2017-01-10 16:01:39.281:INFO:oejus.SslContextFactory:main: x509=X509@7a0ac6e3(rootca,h=[],w=[]) for SslContextFactory@71be98f5(file:///Users/schalkgreyling/Documents/macserver_25/key/key.jks,null)
2017-01-10 16:01:39.281:INFO:oejus.SslContextFactory:main: x509=X509@6fadae5d(jetty,h=[],w=[]) for SslContextFactory@71be98f5(file:///Users/schalkgreyling/Documents/macserver_25/key/key.jks,null)
2017-01-10 16:01:39.538:INFO:oejs.ServerConnector:main: Started ServerConnector@4d85841a{SSL,[ssl, http/1.1]}{}
2017-01-10 16:01:39.539:INFO:oejs.Server:main: Started @639ms
Build server is ready
Build server version: 2.51

Safari (

B4i Build Server

Build server is running.

Version: 2.51

Server time: 16:02:43

Mac SSL Key

Key IP:

SSL port: 51042

h files

iAd: 1.00
iAdMob: 1.30
iAnalytics: 1.0
a files

[*]libCore, size=3,507,040, modified=02/28/2016 15:38:34
[*]libiAd, size=36,880, modified=02/22/2016 11:22:22
[*]libiAdMob, size=68,176, modified=02/22/2016 11:22:22

From B4i:

B4i version: 2.51
Parsing code.    (0.01s)
Compiling code.    (0.29s)
Building designer app.    (0.09s)
Building Xcode project    (0.10s)
Sending data to remote compiler.    (10.45s)
    Open mobile Safari and navigate to:
Then click on the Install button.
1. Make sure that B4I certificate is installed (
2. Make sure that the provisioning file includes the target device UDID.
3. Check the link for typos.
Completed successfully.

From Mobile (Safari :

When I click install app (Firewall disabled, the installation works when I publish to the same server from my windows laptop):
Upvote 0


Licensed User
Woooot thank you Erel.

The problem was I needed to not only by shut down the VM, but actually closing the software(Parallels). Only then does the SSL IP change to Mac IP (changing the key.txt does not change the SSL IP).
Upvote 0


Licensed User
I tested the scenario now again maybe it is only related to using Parallels (or something weird on my pc), but using
manual:<correct ip address>
does not update the SSL IP if parallels is still open, even when windows is shut down. Only after closing parallels does the SSL IP change upon launching the mac builder. Setting the Key IP to manual does change the Mac Builder (web) address to the correct one just not the SSL.
Upvote 0