iOS Question Main.o and iTunes Connect

fbritop

Active Member
Licensed User
I have tried 3 times to upload the Archive.zip to iTunes. It keeps "processing" forever on iTunes, while I receive an email with every upload with the following info:

Dear developer,
We have discovered one or more issues with your recent delivery for "XXXXXX.COM". Your delivery was successful, but you may wish to correct the following issues in your next delivery:
Invalid Bundle Structure- The binary file 'LlaveMovil.app/main.o' is not permitted. Your app can’t contain standalone executables or libraries, other than the CFBundleExecutable of supported bundles. Refer to theBundle Programming Guidefor information on the iOS app bundle structure.
After you’ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to iTunes Connect.
Regards,
The App Store team

Any ideas on how to correct this?
Thanks
FBP
 

fbritop

Active Member
Licensed User
Select a build before you submit your app.
Submit your builds using Xcode 5.1.1 or later, or Application Loader 3.0 or later.
 
Upvote 0

tufanv

Expert
Licensed User
Select a build before you submit your app.
Submit your builds using Xcode 5.1.1 or later, or Application Loader 3.0 or later.
yes when you click on it ( or the little plus mark near build ) you should see a build if you could send it
 
Upvote 0

fbritop

Active Member
Licensed User
Attached screen shot...
 

Attachments

  • screen.png
    screen.png
    104.7 KB · Views: 250
Upvote 0

fbritop

Active Member
Licensed User
OK, I'll wait a couple of hours to see whats happening. Does the alert email sent by apple has something to do with getting stuck in processing?

Dear developer,
We have discovered one or more issues with your recent delivery for "********.***". Your delivery was successful, but you may wish to correct the following issues in your next delivery:
Invalid Bundle Structure- The binary file 'LlaveMovil.app/main.o' is not permitted. Your app can’t contain standalone executables or libraries, other than the CFBundleExecutable of supported bundles. Refer to theBundle Programming Guidefor information on the iOS app bundle structure.
After you’ve corrected the issues, you can use Xcode or Application Loader to upload a new binary to iTunes Connect.
Regards,
The App Store team
 
Upvote 0

tufanv

Expert
Licensed User
it generally takes about 15 minutes for processing message to dissapear. I uploaded 2 apps in last 2 weeks this was the case
 
Upvote 0

fbritop

Active Member
Licensed User
In my case after 4 hours still hanging out there

1.5.14 (1.5.14) (Processing) November 03, 2015 12:07 PM
 
Upvote 0

fbritop

Active Member
Licensed User
Erel,
I have uploaded the binary without the main.h file in Special Folder (fetch download function) and I still have the same issue. I also tried to upload the binary with a Mac App Loader (2.9) with no success either

I have been stucked with this for two weeks now, is there any side solution I can take?

The email from apple is:

Dear developer,

We have discovered one or more issues with your recent delivery for "llavemovil.com". To process your delivery, the following issues must be corrected:

Invalid Segment Alignment - The app binary at '/Payload/LlaveMovil.app/main.o' does not have proper segment alignment. Try rebuilding the app with the latest Xcode version.

Missing load commands - The executable at '/Payload/LlaveMovil.app/main.o' does not have the necessary load commands. Try rebuilding the app with the latest Xcode version. If you are using third party development tools, contact the provider.

Once these issues have been corrected, you can then redeliver the corrected binary.

Regards,

The App Store team


Thanks
FBP
 
Upvote 0

schimanski

Well-Known Member
Licensed User
I have the same problem with my App which uses silent Notifikation together with fetch download. Is it possible, that the Main-file,which coppels the two services is the
problem?
 
Upvote 0

Erel

B4X founder
Staff member
Licensed User
Note that you need to use Application Loader 3.0+.

I have the same problem with my App which uses silent Notifikation together with fetch download. Is it possible, that the Main-file,which coppels the two services is the
problem?
It is possible. Please try to use the default main file and see whether this error disappears.
 
Upvote 0
Top