MP3 player on version 6.1

Discussion in 'Beta Versions' started by derez, May 24, 2009.

  1. derez

    derez Expert Licensed User

    The attached player runs on my MIO 350 (WM 5).
    I checked it on an emulator of version WM6.1 - gets an error :
    "Error loading program. Exception."
    But when I run it from B4PPC on the device - its OK.

    Is there an explanation ?:confused:

    Due to size limit I uploaded only the code, the exe and the list of files which are required for the compilation.
     
    Last edited: May 24, 2009
  2. LineCutter

    LineCutter Active Member Licensed User

    I was going to try it on the beta version installed here but...

    "Invalid Attachment specified. If you followed a valid link, please notify the administrator"
     
  3. klaus

    klaus Expert Licensed User

    I wanted to try it in the desktop IDE, but it doesn't run because of the missing image files.
    I tried the exe file on my htc Touch HD, get an error in loading program.

    Best regards.
     
  4. derez

    derez Expert Licensed User

    Klaus
    Sorry for my ignorance, is it running on WM6.1 ?
    Linecutter - what is your device ?

    Thanks for testing.
    I attach the images.

    Edit: Tried it on the same emulator type on my Laptop with the same results.
     
    Last edited: May 25, 2009
  5. klaus

    klaus Expert Licensed User

    Hi derez,

    I tryed the program again. I can't run it on the desktop.

    But I compiled it with Device(AutoScale):
    - works on my Qtek 9090 WM2003
    - doesn't work on my htc Touch HD WM6.1 I get the error below

    Compiled it with Device Exe:
    - doesn't work on WM6.1 either.

    Sorry for the bad news.
    I dont know what the problem is.
    Is it the FMODDevice.dll or is it the fmodce.dll ?

    Best regards.
     
  6. derez

    derez Expert Licensed User

    I post it here since I believe it is a bug in 6.76.
    Since you get a problem with a real device - it is not the problem of the emulator.
    As I said - it runs with the Device IDE and also on WM5 on the device.

    I also checked "simple MPG player" after adding the device dlls, and it works as exe on the device, so the problem is probably not with the FMOD family of libraries .

    Also tried with deleting the HW and the record - but still the error.
     
    Last edited: May 25, 2009
  7. Erel

    Erel Administrator Staff Member Licensed User

    David, can you please send me a zip file with all required files (including libraries)?
    Did it work with Basic4ppc v6.50?
     
  8. derez

    derez Expert Licensed User

    sent to your mail
    did not check with 6.50 but it used to work there, I added volume control based on the library's volume instead of external application.
     
  9. Erel

    Erel Administrator Staff Member Licensed User

    There is a problem with the .Net CF and the specific format of the png files you are using. Replace those files with files in a different format and it will work fine. (This problem is not related to V6.80)
    I don't know why it works on some devices and doesn't work on others.
    However I see that other .Net CF users encountered it.
     
  10. derez

    derez Expert Licensed User

    True, after changing all the images to jpg format the problem does not show.
    But still, why does it not appear when running the same application from the device IDE ?
     
  11. Erel

    Erel Administrator Staff Member Licensed User

    Did you run Basic4ppc.exe or Basic4ppc-VGA.exe on the device?
     
  12. derez

    derez Expert Licensed User

    I was not aware of the existence of B4p-vga. It also fails, so it is consistent.
    I shall replace the 4 problematic png images.
    Thanks.:)
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice