iOS Question My existing projects dosent work anymore

Sasuke Sama

Active Member
Licensed User
I havent used B4I for about a month or so but now i have to updates my apps for IOS 14 stuff however i cant compile any of my projects using the hosted im getting this :

B4X:
B4i Version: 6.80
Parsing code.    (0.09s)
Building folders structure.    (0.08s)
Compiling code.    (0.67s)
Compiling layouts code.    (0.06s)
Compiling debugger engine code.    (2.62s)
Building Xcode project    (0.44s)
Sending data to remote compiler.    Error
Out: Command line invocation:
    /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild -configuration Release PRODUCT_NAME=SAnime CONFIGURATION_BUILD_DIR=/Users/erel/Documents/UploadedProjects/<user id>/Payload "CODE_SIGN_IDENTITY=iPhone Distribution: Mustafa Wahed (TJRGZY6X9A)" "OTHER_CODE_SIGN_FLAGS=--keychain <user id>" PROVISIONING_PROFILE=cf754a12-c97c-4f7d-8a79-0489cb25bae1 -arch arm64

Build settings from command line:
    ARCHS = arm64
    CODE_SIGN_IDENTITY = iPhone Distribution: Mustafa Wahed (TJRGZY6X9A)
    CONFIGURATION_BUILD_DIR = /Users/erel/Documents/UploadedProjects/<user id>/Payload
    OTHER_CODE_SIGN_FLAGS = --keychain <user id>
    PRODUCT_NAME = SAnime
    PROVISIONING_PROFILE = cf754a12-c97c-4f7d-8a79-0489cb25bae1

note: Using new build system
note: Using codesigning identity override: iPhone Distribution: Mustafa Wahed (TJRGZY6X9A)
note: Planning build
note: Constructing build description
warning: MobileCoreServices has been renamed. Use CoreServices instead. (in target 'B4iProject' from project 'B4iProject')
CreateBuildDirectory /Users/erel/Documents/UploadedProjects/<user id>/build (in target 'B4iProject' from project 'B4iProject')
    cd /Users/erel/Documents/UploadedProjects/<user id>
    builtin-create-build-directory /Users/erel/Documents/UploadedProjects/<user id>/build

MkDir /Users/erel/Documents/UploadedProjects/<user id>/Payload/SAnime.app (in target 'B4iProject' from project 'B4iProject')
    cd /Users/erel/Documents/UploadedProjects/<user id>
    /bin/mkdir -p /Users/erel/Documents/UploadedProjects/<user id>/Payload/SAnime.app

ProcessProductPackaging /Users/erel/Library/MobileDevice/Provisioning\ Profiles/cf754a12-c97c-4f7d-8a79-0489cb25bae1.mobileprovision /Users/erel/Documents/UploadedProjects/<user id>/Payload/SAnime.app/embedded.mobileprovision (in target 'B4iProject' from project 'B4iProject')
    cd /Users/erel/Documents/UploadedProjects/<user id>
    builtin-productPackagingUtility /Users/erel/Library/MobileDevice/Provisioning\ Profiles/cf754a12-c97c-4f7d-8a79-0489cb25bae1.mobileprovision -o /Users/erel/Documents/UploadedProjects/<user id>/Payload/SAnime.app/embedded.mobileprovision

WriteAuxiliaryFile /Users/erel/Documents/UploadedProjects/<user id>/build/B4iProject.build/Release-iphoneos/B4iProject.build/DerivedSources/Entitlements.plist (in target 'B4iProject' from project 'B4iProject')
    cd /Users/erel/Documents/UploadedProjects/<user id>
    write-file /Users/erel/Documents/UploadedProjects/<user id>/build/B4iProject.build/Release-iphoneos/B4iProject.build/DerivedSources/Entitlements.plist

ProcessProductPackaging "" /Users/erel/Documents/UploadedProjects/<user id>/build/B4iProject.build/Release-iphoneos/B4iProject.build/SAnime.app.xcent (in target 'B4iProject' from project 'B4iProject')
    cd /Users/erel/Documents/UploadedProjects/<user id>
   

Entitlements:

{
    "application-identifier" = "TJRGZY6X9A.com.snoanime.iq";
    "aps-environment" = production;
    "com.apple.developer.team-identifier" = TJRGZY6X9A;
    "get-task-allow" = 0;
}

I tried to make a new empty project and used one of my apps cer and prov profiles and it worked just fine so its not a matter of cer or prov

Any ideas please? Thanx
 

Attachments

  • the rest of the error.txt
    144.9 KB · Views: 37
Top