iOS Question Noob going insane trying to Build B4i-Bridge App

Discussion in 'iOS Questions' started by Steve Addy, Jul 15, 2015.

  1. Steve Addy

    Steve Addy New Member Licensed User

    Please can someone help.

    I have B4i running on my PC.
    I have B4i Build Server running on my local Mac.
    I can load up the examples on the PC and see them/run them on the Xcode/Ios Simulator on the Mac.

    I have paid my 99USD, set up certificates,ids,provisions etc... on the apple site and downloaded files to my keys folder. I presume I need these to get the app onto my ipad.

    Don't say, watch the videos! I've been through them all at least 20 times! The Beginners guide and this forum just seem to say watch the videos.

    Please can someone give some straightforward answers to the following dumb questions:

    1. What is the B4i-Bridge App? Is it an app on the PC, Mac or my ipad? Why do I need it?

    2. If at apple I have set up my app id as com.fred.* and then linked this with my certificate and ipad UDID in the provision profile. All of which I have downloaded to the keys directory (on the PC),
    what should I be saving the B4i app as? com.fred.example1 should that work?

    3. I presume at apple.developer.com I do not need any Mac apps certificates/ids/provisions, only IOS apps...

    3. I have got that B4i certificate on the ipad, do I have to do anything else on the ipad?

    4. Do I connect the ipad to the PC or the Mac?

    I am stuck at the following:
    I seem to have to have the Build Server running on the Mac.
    I seem to have to have xcode running on the Mac.
    I can plug the ipad into the Mac or the PC and it makes no difference.
    I create a new project, save it and set the Build Configurations/Package name to com.fred.example1
    I try Tools/Build Server/Build B4i-Bridge App and I get the following error


    Check dependencies
    Code Sign error: No codesigning identities found: No codesigning identities (i.e. certificate and private key pairs) that match the provisioning profile specified in your build settings (“Development”) were found.
    CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 8.4'


    Error: ** BUILD FAILED **
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    1. Device app.
    2. Yes, it should work.
    3a. Correct.
    3b. No.
    4. Do you mean with a cable? You don't need to connect it at all.

    Please contact support@basic4ppc.com and we will send you a temporary id to the hosted builder. This will help with debugging the issue.
    Another thing that you should try is to revoke all certificates in Apple site. Delete the files in the keys folder and start the process from scratch.
     
  3. Steve Addy

    Steve Addy New Member Licensed User

    Revoking the certificates, deleting the files in the key folder has got me much further than before. Maybe, because I've disconnected the ipad from the Mac and/or PC.

    So now I've got the B4i-Bridge app on the ipad, added the device ip address to the IDE.

    Now my problem is that when I run the prog in the IDE, the ipad shows the message that the Mac wants to install the App.

    But now on the ipad it looks like it starts to download the app but then comes up with the message:

    "Unable to Download App"
    "B4i Example could not be installed at this time - Done/Retry".
     
  4. tufanv

    tufanv Expert Licensed User

    on your ipad navigate to b4x.com/ca.pem and install the certificate and make sure on your provisioning file you have the ipads device id added.
     
  5. Steve Addy

    Steve Addy New Member Licensed User

    The certificate is correctly installed. I installed it again - but no difference.
    I deleted the B4i-Bridge app and installed that again - successfully. Doesn't this prove that all the certificates/provisions etc... are okay?

    Why do I still get the example app almost appearing on the ipad but when I click on it, it starts to install and then comes up with
    "Installing..."
    Then a window pops up with "Unable to Download app, B4i example could not be installed at this time. Done / Retry"?
     
  6. tufanv

    tufanv Expert Licensed User

    Yes I know the problem. It starts to install , fills the circle a bit than stops. If the provisoning file is crrect ( the device is added ) and you have installed ca.pem it must install. But in one of my ipads i had the same problem and could not resolve the problem. I dont know why maybe i have made a mistake too. Erel had said that open the provisoing file with a notepad or wordpad and see if the deviced id is there . You can check it and confirm the provisiong file is correct.
     
  7. Erel

    Erel Administrator Staff Member Licensed User

    If you were able to install B4i-Bridge and unable to install other apps then go to Tools - Build server and check 32 bit instead of 64 bit.
     
  8. Steve Addy

    Steve Addy New Member Licensed User

    Brilliant. Checking 32 bit sorted it!

    Many Thanks.
     
Loading...