B4A Library NumberProgressBar V2.1.2

Discussion in 'Additional libraries, classes and official updates' started by DonManfred, Mar 29, 2015.

  1. JakeBullet70

    JakeBullet70 Well-Known Member Licensed User

    Hi @DonManfred

    I am having issues with this. If you see below I have created a very simple project and if I add the progressbar via the designer it errors out. If I remove it then all is good. Thanks for all your hard work!

    upload_2016-5-8_19-54-13.png
     
  2. DonManfred

    DonManfred Expert Licensed User

    Post the code you are using please.
     
  3. JakeBullet70

    JakeBullet70 Well-Known Member Licensed User

    That is the code in the picture. I had an issue in a larger project so I created a test project and that is what you see. I zipped it and it is attached.

    Thanks.
     

    Attached Files:

  4. Dave O

    Dave O Active Member Licensed User

    Hmm, just upgraded from 2.10 to 2.11 and I'm getting the same error.
     
  5. DonManfred

    DonManfred Expert Licensed User

    See updated lib in Post #1. V2.1.2
    I did a mistake... Fixed
     
    Leni Berry and JakeBullet70 like this.
  6. Dave O

    Dave O Active Member Licensed User

    Confirmed, v2.1.2 is now compiling and running well.

    I did notice 2 minor oddities: If I set Color or Visible in the designer, those settings are ignored. If I set them in code, they work properly.
     
  7. DonManfred

    DonManfred Expert Licensed User

    I´ll check this
     
  8. Fausto Loss

    Fausto Loss Member Licensed User

    Hi Don, thanks this lib !!!

    I have a problem (used v 2.1.2), please help !
     

    Attached Files:

  9. DonManfred

    DonManfred Expert Licensed User

    Without seeing your project i hardly can help. Upload a Small project which shows the problem.
     
  10. Fausto Loss

    Fausto Loss Member Licensed User

    I used NumberProgressBar_example.zip and B4A 6.50
     
  11. DonManfred

    DonManfred Expert Licensed User

    i tried the example too.
    On the first run i got the same error.

    Try to open the Designer, load the layout and just save it again.
    Run the project again.
     
    Fausto Loss likes this.
  12. Fausto Loss

    Fausto Loss Member Licensed User

    HAhahaha, WORKS MAN !!! Thanks !!!
     
  13. Fausto Loss

    Fausto Loss Member Licensed User

    There is still a small problem:
    the message
    Lib: NOTFOUND 'numberprogress_onprogresschange
    Appears several times.
     
  14. DonManfred

    DonManfred Expert Licensed User

    Add the missing eventsub!
     
  15. Fausto Loss

    Fausto Loss Member Licensed User

    Sorry, but can you show me an example?
     
  16. DonManfred

    DonManfred Expert Licensed User

    See the beginners guide how to work with the designer and how to create the event-sub. This is B4A in it´s basics
    You can even create the sub manually.

    Code:
    Sub NumberProgress_onProgressChange(current As Int, maxvalue As Int)
       
    End Sub
     
  17. Fausto Loss

    Fausto Loss Member Licensed User

    Thanks ! Works Fine !
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice