Please configure paths ...

lemonisdead

Well-Known Member
Licensed User
[SOLVED] Please configure paths ...

Hello,

I am lost and will need your help please because I tried many solutions without any fix. Of course, I have browsen the forum and read, read, read. I ensure you.

I was used to B4A for a long time. My DevStation was working perfectly till this morning. I did not change anything in the configuration manually. But, each time i want to compile, I get the famous :

"Generating R file. Error
Cannot find: C:\Program Files\Android\android-sdk\tools\..\platform-tools\aapt.exe
Please configure paths (Tools - Configure Paths)."


After, having got this error, I have checked my paths but they did not change. Tried to fix them manually without success.

I even have tried to do the install in reverse mode : uninstall the A SDK and even Java. But the new install did not repair.

Please, please, please... Would you be kind enough to point me to any idea as I would like to be able to use B4A again.

My current paths Inside B4A are :
- C:\Program Files\Java\jdk1.7.0_21\bin\javac.exe (it was 1.6 before I redownloaded a fresh copy)
- C:\Program Files\Android\android-sdk\platforms\android-8\android.jar

Thanks per advance. :BangHead:
 
Last edited:

lemonisdead

Well-Known Member
Licensed User
Thank you very much Klaus. I had already tested the solution provided in this thread but it was not fixing the issue.

I had to add the global path to C:\Program Files\Android\android-sdk\platform-tools to the system environnement variable.

After rebooting, the issue is fixed.

Best regards
 
Upvote 0
Top