Android Question Potentially an issue with the new B4A 5, recognising working B4A 4 views

Simon Smith

Active Member
Licensed User
Hello

I opened the exact same project I have opened always with B4A5 today instead of B4A4. Never had an issue with the designer. Today on opening the designer I get this message.

upload_2015-6-17_13-14-22.png


What used to work fine and now looks like this in the Designer (which I'm not fussed with) - has issues only now.

upload_2015-6-17_13-18-9.png


As when I go Send to UI Cloud I get this error:

upload_2015-6-17_13-19-3.png


It clearly doesn't like it because the UI cloud gives weird and improper screens in this version as below when it used to work perfectly. It's just a standard layout with all members generated.

Galaxy Note (5.3" phone)

Process time: 3.42 seconds
Galaxy S4 (5'' phone)

Process time: 2.98 seconds
Galaxy Tab (10" tablet)

Process time: 3.34 seconds
HTC One S (4.3'' Phone)

Process time: 2.89 seconds
Nexus 4 (4.7" phone)

Process time: 2.75 seconds
Nexus 7

Process time: 2.72 seconds
Samsung I9000 (4" phone)

Process time: 2.59 seconds
Samsung Pocket (2.8" phone)

Process time: 3.22 seconds
Tablet Kindle Fire




Not sure guys? Anyone?


Is this a bug?
Simon
 

Simon Smith

Active Member
Licensed User
It clearly doesn't like it because the UI cloud gives weird and improper screens in this version as below when it used to work perfectly. It's just a standard layout with all members generated.
Note those images above didn't paste, but they were big black screens with the tiny test layout in the bottom right hand corner for each device.
 

Simon Smith

Active Member
Licensed User
Hello I did this and I confirmed that B4A5 fixed the error itself (somehow) on save, but now I can safely say that out of the box B4A5 and iOS (at least when upgrading from a B4A project - I will make a dummy semi-useful app) is Impossible to work and get published on the Appstore. I have had one version rejected from a Black Screen.

I just received the next rejection for the most basic App. There are related problems and this is the appropriate forum. Firstly after receiving the first rejection, I phys

1. Launch images do not work with B4A and iOS8. Can somebody please show me an example I can compile in release mode that shows a launch image. All my devices do not show. Plus, although I started a layout a different way in iOS8, it was still rejected on some devices. Is there a 100% sample with every image resolution imaginable on earth that any Apple device would use with sample Hello World code that will compile in iOS8.

2. Has anyone done it? If so may I ask your help.

From Apple #2 time - now different devices. The screenshots are pitch black images.





2.2 Details

We discovered one or more bugs in your app when reviewed on iPad Air running iOS 8.3 iPhone 5s running iOS 8.3 on both Wi-Fi and cellular networks.

When launched, the app brings up a blank screen.

We’ve attached screenshot for your reference.

Next Steps

Please run your app on a device to identify the issue(s), then revise and resubmit your app for review.

If we misunderstood the intended behavior of your app, please reply to this message in the Resolution Center to provide information on how these features were intended to work.

For new apps, uninstall all previous versions of your app from a device, then install and follow the steps to reproduce the issue(s). For updates, install the new version as an update to the previous version, then follow the steps to reproduce the issue(s).
 

Simon Smith

Active Member
Licensed User
I'm sorry I have B4A in my mind, please treat it as a reference to B4I latest version. Sorry that would mean the wrong thread, I shall update it.
 
Top