Android Question Problem Loading Website

Never99

Member
Hi everyone, I have difficulty, via webview and, precisely, via webview.loadurl to show this site = https://purechaose.github.io/r6maps/#consulate/1/all
it remains loading and is not shown while, if I search for it via google, it loads quietly.
the connection to the site occurs, the home page is loaded and displayed but on this appears a kind of progress bar (circular) which indicates that it is trying to load something else but without this succeeding, that is to say endlessly.
it is a matter of b4a but I don't understand how to solve it ... advice?


ps. I cannot use other sites as what I need is only on this site.
(sorry for my english🤣)
 

DonManfred

Expert
Licensed User
Search the forum about webview and adding a chromeclient and enable javascript.
 
Upvote 0

Erel

B4X founder
Staff member
Licensed User
it is a matter of b4a but I don't understand how to solve it ... advice?
B4A doesn't load the website. It is the native WebView that loads the website.
I guess that this site uses features not supported by WebView.

Adding a WebChrome to WebView might help (probably not). Worth trying.

 
Upvote 0

JohnC

Expert
Licensed User
The tip #1 in my below signature shows how to add the chromeclient to webview...
 
Upvote 0

JohnC

Expert
Licensed User
This might help you get a start with using webview:

 
Upvote 0

Never99

Member
This might help you get a start with using webview:

i know how to use it webview, it doesn't take me a tutorial. I'm asking how to fix this problem with that site not loading me, that's all.

I'm asking a little favor and help from you who are experts, to speed up my project, so as to also understand how to do it in the next projects, if it happens to me, and learn how to solve this type of problem.
 
Upvote 0

JohnC

Expert
Licensed User
Hi,

We first suggested that you add the chrome client to webview and turn on javascript because that might allow the page to load properly.

Then in post #5 you said you didn't know how to do it, so we assumed "it" was that you didn't know how to add the chrome client, so we sent you links on how to add the chrome client.

Then in post #7 you indicated that you didn't even "know how to start", so I assumed you didn't know how to use webview, so I suggested a tutorial on how to.

So what EXACTLY do you NOT know how to do?

Providing as much info as possible will help us help you.

So did you add the chrome client and enable javascript?
 
Last edited:
Upvote 0

Never99

Member
Hi,

We first suggested that you add the chrome client to webview and turn on javascript because that might allow the page to load properly.

Then in post #5 you said you didn't know how to do it, so we assumed "it" was that you didn't know how to add the chrome client, so we sent you links on how to add the chrome client.

Then in post #7 you said you indicated that you didn't even "know how to start", so I assumed you didn't know how to use webview, so I suggested a tutorial on how to.

So what EXACTLY do you NOT know how to do?

Providing as much info as possible will help us help you....so did you add the chrome client and enable javascript?
no, you were available and for that I thank you.
no chrome client and java I didn't insert them, can you help me insert them? so we see
 
Upvote 0

JohnC

Expert
Licensed User
You said you know how to use webview, so we then supplied you the link on how to add the chrome client:
B4X:
Dim wv as WebView
Dim wve as WebViewExtras   
wve.addWebChromeClient(wv, "WVE")

The above adds the chrome client.

To enable javascript:
B4X:
wv.JavaScriptEnabled = True

Do you understand this?
 
Upvote 0

Never99

Member
You said you know how to use webview, so we then supplied you the link on how to add the chrome client:
B4X:
Dim wv as WebView
Dim wve as WebViewExtras
wve.addWebChromeClient(wv, "WVE")

The above adds the chrome client.

To enable javascript:
B4X:
wv.JavaScriptEnabled = True

Do you understand this?
so far everything ok, I don't understand why it tells me that addwebchromeclient is an unknown member, why?
 
Last edited:
Upvote 0

JohnC

Expert
Licensed User
What version of webviewextras are you using?
 
Upvote 0

JohnC

Expert
Licensed User
The correct method name is ".addwebchromeclient" - it seems you left out the word "web".
 
Upvote 0
Top