Android Question Problem opening designer on B4A 5.02

Discussion in 'Android Questions' started by MFX, Jun 21, 2015.

  1. MFX

    MFX Member Licensed User

    Hi I haven't used B4A for AGES but recently upgraded to 5.02 on a Windows 8.1 machine, using it with a Nexus 5 and WiFi bridge connection. I can't get the designer to open/work on the phone, the bridge is showing as "connected", sometimes the designer screen will open but that's all, no views (buttons etc.) appear on the phone screen when I create them on the PC, other times (most of the time in fact) the designer screen won't even open. I've tried unintalling designer from the phone and re-installing it with no luck. Also (I don't know if this is relevant) if I select "WYSIWYG designer - Connect" I get :-

    "An error has occurred The calling thread must be STA, because many UI components require this. Restarting ADB server may solve this problem"

    Restarting ADB server doesn't solve it.

    I have no issues with B4A 3.82 (which I still have installed)
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    This is strange. Note that I use Nexus 5 most of the time and it works properly here. Can you try to enable usb debug mode and see whether it works in this mode?
     
  3. MFX

    MFX Member Licensed User

    Solved it, the paths weren't set up, 3.82 helpfully warned you that they weren't 5.02 doesn't :-(.

    Thanks
    Martin.
     
    RandomCoder likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice