Android Question "Process timed out" when compiling after adding Google and Facebook login


Active Member
Licensed User
Since I added Google and Facebook logins when I try to compile I get this error:

Convert byte code - optimized dex.    Error
Process timed out.
You can change it under Tools - IDE Options.

I've read many threads about this and I've tried disabling the dex optimizing (UseOptimizedDexer) in the .ini (reloaded B4A). I've tried increasing the timeout IDE Options/Configure Process Timeout.

It keeps timing out. When viewing Task Manager java.exe is using nearly 100% (this is an i7 with 16 GB RAM).

I have used the small test app and even that times out. If I remove the libraries and any code that references it and then compile it compiles. I can then uncomment the code and re-add the libraries and it will compile. But the app I'm trying to add it to won't compile

Right now my CPU (java.exe) has been running at 100% for probably 10 minutes! I need to manually kill it.

What is going on? Please advise ...

PS: The facebook library is version 1.00 and FirebaseAuth is 1.06.