iOS Question Provisioning profile doesn't match bundle id


Active Member
Licensed User
I am an experienced B4A user but am new to B4I. I have just successfully installed B4I and the B4I-Bridge (Phew!!! - see below). I am trying to compile and run the first sample program that came with the installation package - MyFirstProgram. I get the following error while compiling:

Check dependencies
Provisioning profile "DicksProfile" has app ID"com.dickddomain.*", which does not match the bundle ID"anywheresoftware.b4i.example".
Code signing is required for product type'Application' in SDK 'iOS 10.1'

I tried changing the changing the build configuration to several different things but none worked. I guess I don't understand the relationship between the Build Configuration as I installed it and the info in the bundle Id for the app. What do I have to do to make the sample program run?

Also the information in the "Creating a certificate and provisioning profile" video has changed. Selecting devices is a separate menu option that has to be completed before creating the profile. And you can only create 1 to 100 development devices by entering the UDID of each one. The video should be updated.