Push Notification Framework Problem

Bill Norris

Active Member
Licensed User
AM working with the sample files for Push Notification Framework. Device showed "registration successful." Now, when attempting to send message using the desktop C2DM batch file, I am getting error in the command prompt "Error getting authentication code......," yet within the message the email address and password shown for the google account are correct. What am I missing here??
 

Bill Norris

Active Member
Licensed User
RE:

Started from scratch on a different computer last night, and all is well. So, I must have goofed up something on the other machine. I have a few followup questions. If you want a new thread, plz advise.

1: In the Desktop side of the push, we put our mail address and password in config.txt. Is there any way to "bury" that in the program for security purposes so it is not there for others to see?

2: I know I will need to modify and setup the web_service.php on a web server. I don't know PHP, but I have friends that do. Is it safe to assume they will know what changes to that PHP file need to be made?

3: Once the web service is setup, it looks as though it is simply a matter of
registering each device to the server with a unique identifier?

4: And, lastly, I ultimately will have approx 20 devices running the app, which will all need to be updated using push. When you send the push message using the desktop app, do you need to send a separate message for each device, or can you incorporate multiple device names into the command?

Thanks for your help. It is truly an exception to have the brains behind the software participate in the forum as much as you do.
 
Upvote 0

Bill Norris

Active Member
Licensed User
I think I've got everything set up as described but obviously not. Device shows Registration Successful. When I try to send msg with desktop, I get an error that says Invalid Registration -- (device name) removed from database. When I do a GetAll, I get:

HTML:
<br /><b>Warning</b>:  mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Can't connect to local MySQL server through socket '/usr/local/mysql-5.0/data/mysql.sock' (2) in <b>/home/content/p/a/r/parksquare/html/tablet/c2dm_board.php</b> on line <b>9</b><br />
Can't connect to local MySQL server through socket '/usr/local/mysql-5.0/data/mysql.sock' (2)

In the php script, the first line is $databasehost = "localhost" -- does that by chance need to be changed to something else when setting up on a different web server from yours?
 
Last edited:
Upvote 0
Top