Android Question RDC and No-IP Address


Active Member
Licensed User
Longtime User
Hi Guys
Really embarrassed to be asking this but have been stuck on it for a while now and for somebody that has been using RDC since it was first introduced, it's bad.
I've been away fro B4A for a year now and just after that my Windows server crashed. I'm now trying to get my application back up and running but have run into a connection problem.

As background, I'm running free Avast (don't believe it has a firewall), malwarebytes, and windows defender with the option to display a message if it blocks anything - I have also disabled it but it made no difference. I've also specifically allowed port 17178, not sure if I've done this right because the instruction were for a different version of Control Panel.

I can run "" and "" successfully, ie get the message
"RemoteServer is running (Thu Jun 23 15:55:09 ICT 2016)
Connection successful."

ipconfig gives me the ip address of my PC as used above

BUT when I try to connect through a browser with my No-IP address it times out - I can get my No-IP address through their DUC utility which I have running all the time.

If I do a nslookup on my No-IP it comes back with the same external IP Address

I've set up port forwarding to 17178 for using TCP and UDC

If I run for the external address for port 17178 it tells me that it cannot see port 17178. In fact if I enter any port in there eg 21,22,23,80,110 it can't see those either - I thought that these were standard.

What stupidly simple thing am I missing

Hope that I have provided enough information.

Thanks for your patients


Active Member
Licensed User
Longtime User
Thanks for your reply Erel, I've been battling with this for a couple of weeks now - still not solved. I'm sure it's not a B4A problem, that's why I haven't been back.
I've had my internet provider here - they were next to useless - didn't understand anything about port forwarding - I'm sure somebody in the organization does but they weren't interested in finding that person for me. They did say that they don't block any ports but that could mean anything?????
I've got looking at it but so far they haven't solved it - but at least they are still looking.
If they can't solve it , I only see one option, going back to my previous provider.
I'll come back here first to see if anybody has any ideas

Upvote 0