B4J Question RDP and B4J in Debug mode

yo3ggx

Active Member
Licensed User
Hi,

I'm using RDP to connect to the computer where B4J is running, as I need access to some local USB devices. Everything is working perfect in Release mode, but in Debug mode the application GUI is not started, without any error. Is this a normal behavior?

Thank you.
 

yo3ggx

Active Member
Licensed User
Thank you for the hint. I've disabled Windows Firewall and now it works. Do you know what ports to open in order to work in debug mode?
 
Upvote 0

yo3ggx

Active Member
Licensed User
Local, no bridge, but currently works only with the firewall off, so debug mode needs something usually blocked by the firewall.
 
Upvote 0

EnriqueGonzalez

Well-Known Member
Licensed User
in the RDP platform you have installed B4J? and you are running your app in debug mode there... am i wrong?

if yes, indeed you have to open ports.

i do not remember what port it is but the IDE tells you when you try to compile 2 b4j apps in debug mode at the same time.
 
Upvote 0

MicroDrie

Active Member
Licensed User
i do not remember what port it is but the IDE tells you when you try to compile 2 b4j apps in debug mode at the same time.
Port UDP 58912 is used for auto discovery of B4A-Bridge clients, the B4A-Bridge on the device listens on port 6789, and the Debugger alternate ports are 9054 and 9055.
 
Upvote 0

yo3ggx

Active Member
Licensed User
Yes, I'm working remotely (through RDP) on my main PC with B4J installed, in debug mode (running the code on remote computer). If firewall not disabled, the app can be run only in Release mode, otherwise the app is compiled, but waiting for debugger to connect. Excelent hint!

Log:
Waiting for debugger to connect...
shell switching to alternate port: 9054
shell switching to alternate port: 9055

Opening the TCP ports 9050-9060 for inbound connection solved my issue.

Thank you.
Dan
 
Upvote 0
Top