#Region "feature"

Discussion in 'Bug Reports' started by agraham, Jan 11, 2009.

  1. agraham

    agraham Expert Licensed User

    If I have a region defined as

    #Region The public subs
    ...
    #End Region

    When collapsed the region description is just

    +subs

    Anything before and including the word "subs" is not displayed :(
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    Interesting...
    Will be checked.
     
  3. Cableguy

    Cableguy Expert Licensed User

    The word causing this issues apears to be "Subs"...
    I've tryied with other variations such as "Sub" and "Sub-Routines" and in all cases only the last word does show as the Region name...

    I would suggest, just to make sense of the region name, to use the word "Routine" as a substitute for "Sub"
     
  4. taximania

    taximania Well-Known Member Licensed User

    I've just tried

    #Region Insubordinate
    it shrinks to
    +subordinate :)
    In other words you can't (ish) use the letters 'sub' or 'subs' in a #Region statement.

    How strange :sign0137:
     
  5. CryoGenID

    CryoGenID Active Member Licensed User

    I can confirm this:

    if you enter:
    Code:
    #Region "Subs called remotely"
    and you minimize the Region it looks like this:

    Notice the missing quotation mark on the left...

    But it is just a small graphical bug ;-)

    Best regards,

    Chris
     
  6. Erel

    Erel Administrator Staff Member Licensed User

    This is fixed in version 6.80.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice