s.bas Module and Obfuscation


Active Member
Licensed User
Longtime User
First off, Margret, wonderful module... much props! (for those wondering, from here: http://www.basic4ppc.com/forum/basic4android-getting-started-tutorials/10365-string-functions.html#post57671

On to my issue:

when trying to compile in obfuscate mode I get the following error:

Compiling code. 0.03

ObfuscatorMap.txt file created in Objects folder.
Compiling layouts code. 0.00
Generating R file. 0.00
Compiling generated Java code. Error
B4A line: 148
Text = Trim(Text)
javac 1.6.0_31
src\b4a\pasagosoft\standardprostart\s.java:152: cannot find symbol
symbol : variable _ba
location: class b4a.pasagosoft.standardprostart.s
_text = _vvvvvvvv2(_ba,_text);

and the cursor is floating in here:

Sub IsEmpty(Text As String) As Boolean
   Text = Trim(Text)
   If Text.Length < 1 Then
      Return True
      Return False
   End If   
End Sub

I've looked thru the pitfalls with using obfuscation from http://www.basic4ppc.com/forum/basic4android-getting-started-tutorials/13773-android-code-obfuscation.html#post77873, and don't see anything that stands out... no process globals that are in my Main (it compiles obfuscated before I add in the S.bas module) No CallSub anywhere that I can see.

Anybody else get this to compile in obfuscate mode? What's the trick? :)

Thanks much,



Active Member
Licensed User
Longtime User

I am using 1.92.

I did a a fresh project, saved it and added the latest s.bas (so it is the only module, and no code written in the Main module)

I select compile(obfuscated) and get the same error.

Any ideas what would cause it? Every other compile works fine (from release method, to obfuscate with other modules)


Quick Edit:

(I went back to a 1.8 and 1.9 version and get the same error)

my paths are (in case that should matter)
C:\Program Files\Java\jdk1.6.0_31\bin\javac.exe
C:\Users\MacBook Pro\android-sdks\platforms\android-8\android.jar
additional libraries
Last edited:
Upvote 0


Active Member
Licensed User
Longtime User
Hair Pulling... and eureka moment.. I think...

Just to follow up.

Did a fresh install to a different directory. (did not uninstall old version)

Got the same error on a fresh project.

I did not get any errors when compiling release or debug.

I could compile other modules (dbutils, my own modules) in any mode.

So then I started trying to pull out the parts that obfuscator was choking on.

Which led me to discover that I could compile part of the module. Then I took the parts that wouldn't compile and moved to a new code module.

Wala! it worked.

So then I took the whole module, copy/pasted into a new code module and everything is good.


Upvote 0