SDK und AVD Manager startet nicht (Windows 7, 64 Bit), bitte Hilfe

Leo10

Member
Licensed User
Hallo zusammen,

Ich wollte Basic4Android und Android SDK installieren (laut Tutorial hier im Forum). Bei meinem alten Laptop mit 32 Bit hat alles sofort geklappt und ich konnte schon "Hello World" zum laufen bringen.

Aber beim 64 Bit Laptop (Windows 7) kriege ich SDK und AVD Manager leider gar nicht zum laufen.

Ich habe zuerst wie im Tutorial beschrieben JAVA JDK 7 (Windows X86) installiert. Dann bei der Installation des SDK findet er auch eine gültige Java Anwendung. Um die restlichen Komponenten des SDK zu laden, soll der SDK Manager gestartet werden und das funktioniert nicht. Es erscheint nur kurz das DOS Konsolfenster und das wars.

Ich habe diesbezüglich schon gegoogelt und alles ausprobiert: Den Pfad von Java beim Umgebungsvariablen beim PATH am Anfang und auch am Ende eingetragen, Rechner neu gestartet, leider ändert sich nichts...

Ich wäre euch sehr sehr dankbar, wenn ihr da noch weitere Ideen und Tipps habt, was ich noch machen könnte...Bitte helft mir...

Vielen Dank im Voraus und viele Grüße
Leo
 

DonManfred

Expert
Licensed User
Auch auf dem 64bit windows muss die 32bit JDK verwendet werden für B4A.
Bei mir ist die in C:\Program Files (x86)\Java\jdk1.7.0_45

Dem entsprechend muss der Pfad in B4A natürlich lauten:
C:\Program Files (x86)\Java\jdk1.7.0_45\bin\javac.exe

Bekommst Du den SDK Manager denn über die Batchdatei SDKpfad\tools\android.bat
gestartet?
 
Last edited:

Leo10

Member
Licensed User
Erstmal danke für die Antwort.

32bit JDK habe ich auch ausprobiert und den Pfad in B4A natürlich angepasst. Aber den SDK Manager und AVD Manager kriege ich immer noch nicht zum starten, hab schon fast überall ausprobiert: über SDKpfad\SDK Manager.exe oder AVD Manager.exe, in B4a über "run AVD Manager", oder auch über SDKpfad\tools\android.bat...auch als Admin ausgeführt...das Ergebnis ist immer das gleiche: Ganz kurz erscheint CMD und verschwindet, dann passiert nichts mehr...

Habt ihr sonst noch andere Tipps? An AntiVirus Programm oder Firewall kann es nicht liegen oder, nicht dass es irgendwie blockiert wird? Ich habe den AVG AntiVirus. Mit Firewall deaktivieren habe ich aber schon ausprobiert.
 

Styx

New Member
Licensed User
Hallo Leo,

der Pfad zum Android-SDK darf keine Leerzeichen enthalten. Wie ist der Pfad bei Dir?
 

AlexMinz

Member
Licensed User
Ich habe dasselbe Problem. Das liegt in meinem Fall daran, dass ich alles installiert habe. Nun weiß ich nicht, wie ich wieder deinstallieren kann, damit er sich wieder öffnet.
 
Top