iOS Question Sending data to remote compiler timeout

Yvon Steinthal

Active Member
Licensed User
Hi,

All of a sudden this morning i am having consistant timeouts when sending data to the remote compiler.
My internet is okay and i've rarely seen this before. Any clues and does this happen to anyone else?

Thanks.

Y.
 

JordiCP

Well-Known Member
Licensed User
If we navigate to the Build server test page, it seems to be 'up': http://208.52.154.96:51041/test , and also this one: http://63.135.170.51:51041/test

But obviously something else is happening that prevents the whole process from working...at least for me

It's not the first time that I experience a similar situation in a short time period. I'm worried that a paid service like this can be down for so many hours.
 
Upvote 0

sorex

Expert
Licensed User
Jordi: it's a pool of servers and your account is locked to 1 specific one. (or it used to be like that) so it could be that those others work fine.

I had no problems at all this morning and it's working now too.
 
Upvote 0

JordiCP

Well-Known Member
Licensed User
Jordi: it's a pool of servers and your account is locked to 1 specific one. (or it used to be like that) so it could be that those others work fine.
It sounds reasonable. My thought was that traffic was dynamically redirected to one or another server, based on load balance, maintenance, or any other criteria, but simply don't know it.
However it is made, and regardless if it only affects some or all of the users, the service MTTR is way larger than what I would consider "reasonable" for a professional service. I have been needing it badly since today at 14:00h and simply can't use it yet.

I am a big fan of B4X in general and I'm really happy with what we get for the prize with B4A and B4I, but this is not the case for the hosted builder service. :(
 
Upvote 0

Jan Kanon PA7X

Member
Licensed User
I also have no compilation service for now , as today I extended my subscription and I was suspecting something was wrong with my updates etc, until I see of this problem. But Servers can pass away temporarely so tomorrow I hope it's back again.
 
Upvote 0

sorex

Expert
Licensed User
I am a big fan of B4X in general and I'm really happy with what we get for the prize with B4A and B4I, but this is not the case for the hosted builder service. :(

$26/year is darn cheap tho. try to find some cloud thing that doesn't charge you $26+/month ;)

but indeed, there's room for improvements.
it's because a similar issue that I remember that erel mentioned that I was on a specific server with a problem and it didn't affect most other users that were connected on another server.

friday evening is sabbat or pre-sabbat if I recall right so I'm not sure if he will check the forum.

maybe it's better to drop a mail to support@ to get his attention?
 
Upvote 0

Yvon Steinthal

Active Member
Licensed User
Its not the first time something like this happend, i am trying to configure my mac to do the compiling instead... might be the best option for me right now...
 
Upvote 0

JordiCP

Well-Known Member
Licensed User
26/year is darn cheap tho. try to find some cloud thing that doesn't charge you $26+/month ;)
Yes it's cheap. But I wouldn't mind paying 2x or 3x that price if I knew that it worked better ;) In fact I own a Mac and hadn't even set up the local builder because the hosted builder solution was perfect for me.--> as Yvon has just written now, I'm going to do the same.

Just to be clear, I'm still a big big fan of B4X :)
 
Upvote 0

Erel

Administrator
Staff member
Licensed User
Sorry about this issue. One of the builders partially hanged. As it was still partially running the monitor system didn't recognize that it is practically offline.
It should work properly now.
But I wouldn't mind paying 2x or 3x that price if I knew that it worked better
If I remember correctly this is the first time that a builder fails for 24 hours in 4 years. Overall the hosted builders service is quite reliable.

Next time if you encounter such an issue please send an email to erel@basic4ppc.com.
 
Upvote 0

Wolli013

Active Member
Licensed User
Thanks

Error: ** BUILD FAILED **


The following build commands failed:
CompileC build/B4iProject.build/Release-iphoneos/B4iProject.build/Objects-normal/arm64/b4i_altimeter.o B4iProject/b4i_altimeter.m normal arm64 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)
 
Upvote 0
Top