Serial2.dll error (V6.01 .Net2)

Discussion in 'Bug Reports' started by almasi, Jan 17, 2008.

  1. almasi

    almasi New Member Licensed User

    Hi,

    I have seen a binary bute transfer error in the Serial2.dll:
    It seems, that using binary transfer (InputArray) the
    incoming byte values 0x11 and 0x13 (decimal 17 and
    decimal 19) can not be read in, these values will not
    appear in the reasult array.
    The serial port settings was 9600-8-N-1, but other
    settings produced the same error. Other byte values are
    coming perfectly, only these two bytes values are missing.
    The place of these two bytes in the input stream is not
    relevant: the same error comes at the beginning, middle
    and at the end of the stream.

    In the "old version" (V5.8, .Net 1.1, DBComm.dll, SerialDesktop.dll) this error was not present.

    Please, colud you help solving this problem?

    Thanks,
    Bela
     
  2. agraham

    agraham Expert Licensed User

    Those are the Xon/Xoff control byte values. It looks like you have Serial2. XonXoffHandshaking set to true.
     
  3. almasi

    almasi New Member Licensed User

    Hi,
    Thanks for the fast answer.

    No, XonXoffHandshaking was explicite set to False. It seems, that the command which sets it to False has no effect. The program below put the "XonXoff True" message on the screen, so confirming that the False setting was not performed correctly:

    Sport.XonXoffHandshaking = False
    If Sport.XonXoffHandshaking = True Then
    Msgbox("XonXoff True")
    Else
    Msgbox("XonXoff False")
    End If

    I guess, it is an error in the DLL.
    Or is there any other kind of way to set the XonXoffHandshaking to False?

    Bye,
    Bela
     
  4. Erel

    Erel Administrator Staff Member Licensed User

  5. agraham

    agraham Expert Licensed User

    It seems to be an error in the DLL! A workaround is to not set XonXoffHandshaking at all as setting it always sets it True. To be sure you could also use:-
    Code:
    Sport.CTSHandshaking = False
    This explicitly sets the Handshake to None if set False.


    Edit :- B****r - Erel got in while I was testing and writing this :sign0142:
     
    Last edited: Jan 18, 2008
  6. almasi

    almasi New Member Licensed User

    Thanks for the fast solution, it works fine.
    Really great work!!!

    Bye,
    Bela
     
Loading...