B4J Question Show keyboard on windows 8.1 tablet pc

avacondios

Active Member
Licensed User
Hi,
I am running a desktop b4j application under windows 8.1 with java 7 and I want automatic to display the virtual keyboard when a textfield has a focus.

help please...
 

FranckB

Member
Licensed User
Hi all,

I try this and it seems to work :

B4X:
#VirtualMachineArgs: -Dcom.sun.javafx.virtualKeyboard=javafx -Dcom.sun.javafx.touch=true

EDIT : work only when running from B4J. Doesn't work when running directly the jar file. An idea ?
 
Last edited:

Erel

Administrator
Staff member
Licensed User
VirtualMachineArgs is only used when you run from the IDE. If you are running your app from the command line then you can add the same arguments:
B4X:
java -jar <your jar> -Dcom.sun...
You can also try to set these properties when the program starts with:
B4X:
SetSystemProperty("com.sun.javafx.virtualKeyboard", "javafx")
SetSystemProperty("com.sun.javafx.touch", "touch")
Whether it will have the same effect depends on the point that JavaFX checks these properties.
 

FranckB

Member
Licensed User
Hi Erel,

Thanks for your response.

The 2 solutions doesn't work. :-(
I 'm still on trying to resolve this pb.

Regards.
Franck
 

FranckB

Member
Licensed User
Running it from the command line must work as this is the same as what happens in the IDE.
However the -jar <jar file> should be last (unlike the line I previously wrote).
Work great like that !
Thks a lot...
 

micro

Well-Known Member
Licensed User
Hi to all
on my raspberry without this directive "
-Dcom.sun.javafx.virtualKeyboard=javafx -Dcom.sun.javafx.touch=true"
the virtualkeyboard show always.
How disable virtualkeyboard show when textfield has focus?
Thanks
 

micro

Well-Known Member
Licensed User
Add this line to your app and see whether it disables the keyboard:
B4X:
SetSystemProperty("com.sun.javafx.virtualKeyboard", "none")
No Erel, the virtualkeyboard always show. :(

It's possible show and hide from code? (Whit Inline java for example)
 
Last edited:
Top