Sms.New1(Number,Text) not working after compilation

Discussion in 'Bug Reports' started by Graley, May 16, 2008.

  1. Graley

    Graley Member Licensed User

    I'm using the Sms.New1 method to send a text with the Outlook.dll (1.0.2900.27217). It works perfectly on my device TyTn II (WM6) through B4PPC, but not after I compile it. I have copied across the very same dll to the application folder, but no joy. Anyone else experienced this? The app used to work before I upgraded to 6.30.

    Well done Erel, the compiling of bitmaps and dll's along with the app is most welcomed.


    Thx

    Graham Aley
     
    Last edited: May 16, 2008
  2. Erel

    Erel Administrator Staff Member Licensed User

    It appears to work fine.
    Please test the attached example (source code and compiled executable).
     

    Attached Files:

  3. Graley

    Graley Member Licensed User

    Solution

    Thanks Erel, all sorted. Not a bug. It turned ou to be a missing CRT in an IF statement. Maybe the old version didn't pick this out. Very stange. Thanks for the prod though.

    Incorrect code:
    If X = X Then
    Action
    ELSE Sms.New1(Number,Message)
    Action
    END IF

    Corrected code:
    Incorrect code:
    If X = X Then
    Action
    ELSE
    Sms.New1(Number,Message)
    Action
    END IF
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice