Spanish [SOLUCIONADO]duda con la b4a 10.70

mvera

Active Member
Licensed User
Longtime User
hola tenia un código que funcionan en b4a 9, recién instale 10.70 , al momento de probar mi código antiguo en la nueva versión salió esto al intentar ejecutar en debug.

Firmando fichero de paquete (clave de depuración) Error
Unsupported option: --v4-signing-enabled. See --help for supported options.

alguien me puede orientar gracias.
 

Omar Parra A.

Expert
Licensed User
Longtime User
ver:

B4A 10.7 depends on a recent version of the build tools. If you get an error similar to:

Signing package file (debug key). Error
Unsupported option: --v3-signing-enabled. See --help for supported options.

Then you are using an old version of Android SDK and need to upgrade. It is very simple to upgrade the SDK: https://www.b4x.com/b4a.html
 

Omar Parra A.

Expert
Licensed User
Longtime User
Yo tengo esto y no tengo problemas:

SDK version: 6609375

1616028894384.png
 

José J. Aguilar

Expert
Licensed User
y te has descargado los archivos que indica Erel en la instalación? mi versión, igual que la de oparra es: 6609375
Tienes que descargar uno de los dos archivos que indica Erel, que recomienda el de OpenJDK 11.

Puedes descargarlo de aquí y descomprimirlo por ejemplo en c:\java.

Después descargar el SDK de Android de aquí y descomprimirlo por ejemplo en c:\Android
Después los recursos requeridos y descomprimirlos en la misma carpeta.

Sigue cuidadosamente las instrucciones de instalación y debería funcionarte.
 

GuruTebar

New Member
Licensed User
y te has descargado los archivos que indica Erel en la instalación? mi versión, igual que la de oparra es: 6609375
Tienes que descargar uno de los dos archivos que indica Erel, que recomienda el de OpenJDK 11.

Puedes descargarlo de aquí y descomprimirlo por ejemplo en c:\java.

Después descargar el SDK de Android de aquí y descomprimirlo por ejemplo en c:\Android
Después los recursos requeridos y descomprimirlos en la misma carpeta.

Sigue cuidadosamente las instrucciones de instalación y debería funcionarte.
Buenos días, al final he conseguido el SDK version: 6609375, he tenido que reinstalar todo y seguir los pasos.
Ya me funciona perfectamente. Gracias.
Podrías indicarme algún tutorial o curso online para aprender a usar los controles y con bases de datos.
Un cordial saludo.
 

José J. Aguilar

Expert
Licensed User
Me alegro de que ya vaya bien.
Por favor, crea nuevos hilos para cada pregunta distinta, para que el foro sea más intuitivo.

Arriba en el menú tienes la opción "Learn" donde puedes ver las guías y videos.
Sería bueno que empezaras directmente con B4XPages. Hace unos días el compañero @Mariano Ismael Castro ha hecho un gran trabajo traduciéndolo al español:


Para bases de datos, la forma recomendada es jRDC2.

saludos,
 
Top