Android Question solved - "app not installed" error

Discussion in 'Android Questions' started by Dave O, May 17, 2015.

  1. Dave O

    Dave O Active Member Licensed User

    Short version:
    If you run into unexpected "app not installed" errors on compiling, unmount your SD card and try again - your app should install now. Then remount your SD card.

    Details:
    Normally I debug my apps on several Android devices with no problems (other my my own bugs :)

    Today, when I tried compiling an app onto my phone, it came back with "app not installed". I tried uninstalling the app, stopping B4A Bridge, rebooting the phone, but nothing helped.

    Some Internet sleuthing revealed this problem for various apps on various devices. It seems to have nothing to do with B4A. Someone posted the solution of unmounting the SD card temporarily. Apparently Android sometimes get confused about where to install apps, and it fails as a result.

    I tried this, and it worked as advertised. Just go into Settings > Storage and unmount your SD card, go back and compile/install your app, then remount the SD card. Not pretty, but it worked for me.

    Hope this helps!
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice