iOS Question [solved] B4XPages - Strange behavior B4XFloatTextField with Toolbar

AymanA

Active Member
Licensed User
Hi All,

I am sure I am doing something wrong as I couldn't find any mention for my problem in the forum.

I have a toolbar1 set to text with tag update.

1603401177744.png


B4X:
Sub B4XPage_MenuClick (Tag As String)
    If Tag = "update" Then
        log("test")
    End If
End Sub

The code above is supposed to work only when the tag update is returned - when I press on the toolbar text, but this is not the case.

Since I have B4XFloatTextField, when I focus (enter to edit/input the field) the code above is triggered!! if I understand correctly it shall only trigger when I press on the toolbar text.

1603401741731.png


I do not have any other fields that has "update" as a tag, as a matter of fact I have checked all the B4XFloatTextField none had tags, so I have specified different tags so It only returns when I press on the toolbar but to no avail! not sure how it see the tag as update when I press on B4XFloatTextField.

Any idea of what I am doing wrong here?

Thank you!
 

Attachments

  • 1603401633532.png
    1603401633532.png
    45.2 KB · Views: 31

AymanA

Active Member
Licensed User
Thank you Erel for your reply, I have attached the project that shall demonstrate the problem - I am trying the B4i project.
 

Attachments

  • Project.zip
    175.1 KB · Views: 33
Upvote 0

AymanA

Active Member
Licensed User
Actually I doubt this is only related to B4XFloatTextField - I have just tested and can see if I even pressed outside of the B4XFloatTextField it triggers the B4XPage_MenuClick as if the tag is update, which is not the desired outcome
 
Upvote 0

Semen Matusovskiy

Well-Known Member
Licensed User
B4XPage_Created is a good place.
Meanwhile I don't see a problem at all. There is no B4XPage_MenuClick event, when I edit B4XFloatTextField1.
Probably a problem in releases (I used (B4i 6.80, IOS 14 simulator).
 
Upvote 0

AymanA

Active Member
Licensed User
Thank you so much for your reply and for testing out, it is indeed strange, I am on 13.5 so will try to update to ios 14 (xcode 12) and will check if it is the same problem or not
 
Upvote 0

AymanA

Active Member
Licensed User
You are right! the behavior doesn't occur on ios 14!! so not really a problem except from the simulator itself :D

thank you so much for your help on this problem.

I will mark this as Solved now!
 
Upvote 0
Top