Android Question [SOLVED] Error compiling after latest Sdk update

Status
Not open for further replies.

Lello1964

Well-Known Member
Licensed User
I have updated SDK yesterday,
today i've tryed compile Apk, before sdk update it's compile right.

Now i have this error :

B4A Versione: 10.70
Analisi del Codice. (1.49s)
Java Versione: 11
Building folders structure. (0.09s)
Compilazione del codice. (3.21s)
Compilazione del codice di layouts (0.76s)
Organizzazione Librerie. (0.12s)
(AndroidX SDK)
Compiling resources (8.55s)
Linking resources (4.04s)
Compilazione del codice debugger. (9.22s)
Compilazione del codice Java prodotto. (14.05s)
Conversione byte code - ottimizzazione dex. Error
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
9 errors; aborting

How solve ?
 

Lello1964

Well-Known Member
Licensed User
Library1=abkeyboardvisible
Library10=ascheckbox
Library11=audio
Library12=base64image
Library13=betterdialogs
Library14=byteconverter
Library15=cameraview
Library16=clipboard
Library17=contentresolver
Library18=core
Library19=cropimageview
Library2=accessibility
Library20=customkeyboard
Library21=dateutils
Library22=encryption
Library23=excel
Library24=firebaseanalytics
Library25=firebasenotifications
Library26=ime
Library27=javaobject
Library28=jhsicezxing1
Library29=jhwifi
Library3=ahlocale
Library30=json
Library31=jssimplearcloader
Library32=keyvaluestore
Library33=maskededittext
Library34=materialbarcodescanner
Library35=materialdialogs
Library36=msmysql
Library37=net
Library38=network
Library39=nineoldandroids
Library4=ahviewpager
Library40=okhttp
Library41=okhttputils2
Library42=phone
Library43=printing
Library44=randomaccessfile
Library45=reflection
Library46=runtimepermissions
Library47=sd_liquidprogress
Library48=sd_menu
Library49=sd_menuclose
Library5=amir_recyclerview
Library50=serial
Library51=sql
Library52=stepview
Library53=stringfunctions
Library54=stringutils
Library55=tabstripviewpager
Library56=ultimatelistview
Library57=vectorcompat
Library58=viewsex
Library59=xui views
Library6=amir_rvparallax
Library60=designsupport
Library7=animatedcheckbox
Library8=appcompat
Library9=arcprogressstackview
 
Upvote 0

msmerce

Member
Licensed User
I have exactly the same problem with firebasenotifications and already tried these steps. I have already done a fresh install. But the error message remains. Does anyone have an idea what this might be?
 
Last edited:
Upvote 0

Erel

Administrator
Staff member
Licensed User
1. Do you see these versions:

1621315922943.png


2. Make sure that the IDE uses the correct Android SDK, under Tools - Configure Paths - android.jar.
 
Upvote 0

prajinpraveen

Active Member
Licensed User
Have the same issue. deleted and installed "datatransport". Still the same error

1621430256844.png


B4A Version: 10.70
Parsing code. (0.06s)
Java Version: 11
Building folders structure. (0.02s)
Compiling code. (0.10s)
Compiling layouts code. (0.01s)
Organizing libraries. (0.00s)
(AndroidX SDK)
Compiling resources (0.05s)
Linking resources (0.37s)
Compiling generated Java code. (0.01s)
Convert byte code - optimized dex. Error
Uncaught translation error: com.android.dx.cf.code.SimException: invalid opcode ba (invokedynamic requires --min-sdk-version >= 26)
1 error; aborting
 
Last edited:
Upvote 0

msmerce

Member
Licensed User
I have exactly the same versions as shown above. Below is a screenshot of Paths Configuration, which has always worked until now.

PathsConfiguration.png
 
Upvote 0
Status
Not open for further replies.
Top