B4J Question [solved] JDBC to MySql on LAN access denied

udg

Expert
Licensed User
Hi all,
I'm running out of ideas on what to check more.
I developed a desktop app using B4J and tested it against an XAMPP's MySql DB on same dev pc: all worked fine. Then I configured the jdbc to look for the needed DB on a Raspberry living on the same LAN and received SQLExecption "access denied for user xxx@x.y.z.88" error.
I've tried to connect from TOAD (same config as JDBC) and got back same error.

On my LAN I have my Raspebrry at x.y.z.99 and my DEV pc on x.y.z.88:

What I checked so far:

** On Raspberry**
mysql is active
mysql's my.cnf file has line "bind-address = 0.0.0.0"
needed dbuser exists in mysql and has was granted all privileges for the right db
firewall allows for any port from LAN (x.y.z.0/24)

**On DEV pc **
firewall rules checked (I even tried disabling the FW, after disconnnecting the ADSL cable as a minimum precaution).
Tried TOAD instead of my app

Note: if I connect as through ssh using TOAD, I can connect and see the DB.

Can you please help suggesting what I forget to check? Thank you.

Edit: problem solved (I'm a donkey!)
What did I forget to check? Well, I had my dbuser with all his nice privileges BUT that was for localhost only! I forgot to grant again those privileges for that same user for LAN access.
Can you waste 2.5 hours for such a basic thing? Shame on me!
 
Last edited:
Top