iOS Question [SOLVED] mac buildserver start issues on mojave and xcode 10.2.1


Active Member
Licensed User
Hi - So I have a fresh install of Mojave 10.14.5 and xcode 10.2.1. I've started xcode at least once, made sure to install any additional items, and created at least one test project with objective c (I didn't try and build it though). xcode appears to be in the application folder.

Whenerver I try to start the local mac build server I'm getting "Failed to find xcode version". Is my version to new? I've searched and I see some posts where mojave works and others that say 10.2 works - I figured a point release should work (but maybe I shouldn't assume).

Here's the error info below:

#java -jar B4iBuildServer.jar

Build server version: 5.8


2019-06-12 19:46:04.379:INFO::main: Logging initialized @164ms to org.eclipse.jetty.util.log.StdErrLog

Loading default configuration file.


Mac version: 10.14.5

Failed to find xcode version.

Michaels-Mac:B4iBuildServer michaelrobinson$


Active Member
Licensed User
I just tested on the same config with an old mac buildserver (from b4i 2.3 I believe) and it starts up fine. So for some reason the most recent build server I downloaded wit v5.8 isn't working...
Upvote 0


Active Member
Licensed User
Hi Erel, the output of xcode-select -p is:


and the output of xcodebuild -version is:
xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance

Hmm, that clearly doesn't seem right, I looked up that error and this pointed me to the fix. Essentially had to ensure:
  1. Install Xcode (get it from if you don't have it yet.
  2. Accept the Terms and Conditions.
  3. Ensure Xcode app is in the /Applications directory (NOT /Users/{user}/Applications).
  4. Point xcode-select to the Xcode app Developer directory using the following command:
    sudo xcode-select -s /Applications/

#4 was what fixed it for me, so the v5.8 Mac buildserver starts up as expected now :) - thank you for your help and pointing me in the right direction!

I've updated the thread title to [SOLVED].
Upvote 0