Android Question [solved] Maven artifact not found androidx.legacy/legacy-support-V4

saunwin

Active Member
Licensed User
Longtime User
Hi,
I want to use runtime permissions, but when I tick the library box I get the above error.
B4A 9.8, latest Java 8, everything works apart from this library.
Searching the forums it seems a common problem, but I've exhausted all the threads and still no joy.
Can anyone guide me what to do next please ?
TIA
 

DonManfred

Expert
Licensed User
Longtime User
Are you using AndroidX?
Can you post the compilation window-text or the full error?

If you are using AndroidX. Open the sdkmanager and search for legacy. Install the found Artifact,

legacy002.png
 
Upvote 0

saunwin

Active Member
Licensed User
Longtime User
DonManfred, All i'm doing is ticking RunTime permissions in the library window to include it. As soon as I tick the box, this pops up. I'm not using android x
1580670052687.png
1580672574325.png
 
Last edited:
Upvote 0

saunwin

Active Member
Licensed User
Longtime User
OK - I'm now using AndroidX, but still the same error. SDK all installed

1580674330693.png


It wil sucessfully complie if I rem out all references to runtime library and remove runtime permissions from the library list

1580675356091.png
 
Last edited:
Upvote 0

saunwin

Active Member
Licensed User
Longtime User
I'm begining to think there is a bug here - as an empty project will not compile with the runtime permissions library included (same error)
 
Upvote 0

saunwin

Active Member
Licensed User
Longtime User
Thanks Peter - this is just the start up project with the runtime permissions library added.
1580684609134.png
 

Attachments

  • B4Atest.zip
    7.9 KB · Views: 133
Upvote 0

DonManfred

Expert
Licensed User
Longtime User
looks like you are using an OLD sdk.

I suggest to install a new sdk. Follow the installationinstructions carefully. It will just work.

 
Last edited:
Upvote 0

DonManfred

Expert
Licensed User
Longtime User
I'll try the SDK re-install first and let you know
Alternative is the readytorun SDK-Download


Please download this zip (369mb) in beforehand so that it is available when i connect.... Only download, not extract. I´ll do it when i am connected.

And please, if you are not english, please configure the ide to use ENGLISH language (the OS is preferred to be in english too.

German and english is OK for me; Chinese, Iran or such languages i do not speak and even can not read 😂
 
Upvote 0

saunwin

Active Member
Licensed User
Longtime User
Alternative is the readytorun SDK-Download


Please download this zip (369mb) in beforehand so that it is available when i connect.... Only download, not extract. I´ll do it when i am connected.

And please, if you are not english, please configure the ide to use ENGLISH language (the OS is preferred to be in english too.

German and english is OK for me; Chinese, Iran or such languages i do not speak and even can not read 😂
Ok Manfred - I appreciate your help with this (I am English :)
 
Upvote 0

DonManfred

Expert
Licensed User
Longtime User
Upvote 0
Top