iOS Question [SOLVED] "Unable to Download App" - can't install B4i-Bridge

Sandman

Expert
Licensed User
I think I've read all forum posts on this topic as I'm not the first one having problems. Tried all that's been suggested, so I'm a little confused. I've historically had this working with an iPhone 5, and that worked fine. (That phone is gone now, so not able to test with it.) The new phone has never had B4i-Bridge installed.

Here's some info:
  • B4i version 4.40
  • iPhone 8 Plus, running 11.1.2
  • Compiling Bridge as 64bit
  • Using Hosted Builder
  • Installed www.b4x.com/ca.pem cert, and enabled it

And some Apple stuff:
  • Added phone as Device on developer.apple.com (UDID doesn't start with ffffff)
  • Added Device to previously used Provisioning Profile
  • Used previously used Certificate in Provisioning Profile
  • Downloaded Provisioning Profile and have double checked that B4i uses it

The Bridge icon on the iPhone "desktop" gets filled to something between 25% and 75% (from 3 o'clock to 9 o'clock), and then I get the dreaded "Unable to Download App - 'B4i-Bridge' could not be downloaded at this time". Does it even mean something how much it gets filled, or is this only cosmetics?

After the fail there's a generic gray icon left behind, which I've tried removing before testing next time - no difference.

Is it absolutely certain the fault is at my end? Or does this sometime happen due to some problem at the hosted builder? And if it's certain the fault is at my end, what could it be?
 

Sandman

Expert
Licensed User
I solved it. Turned out I misread a character in the UDID, and as soon as I corrected that, the Bridge installed without problems.

(It really confused me that the level of fill before fail on the icon varied, made me believe it was something intermittent going on.)
 
Upvote 0
Top