Android Question [Solved]Using Firebase - INSTALL_PARSE_FAILED_MANIFEST_MALFORMED

juan manuel luzuriaga

Member
Licensed User
Hi, to all. I come here to look for some help. I try to add Firebase to my application. I follow all the points, I got the last services of google, Etc. But when I compile I got an error and try many things to figure out. The error goes when I take out the lines of Firebase from manifest. So the last try I made was, creating a new project on firebase "Test.addies" and a simple project on B4A, with just a label. I compile and download project without firebase, all was ok. I add Firebase to manifest and crash. This the error that I got.

B4X:
B4A version: 6.50
Parsing code.    (0.00s)
Compiling code.    (0.31s)
Compiling layouts code.    (0.00s)
Organizing libraries.    (3.78s)
Generating R file.    (1.10s)
Compiling debugger engine code.    (3.16s)
Compiling generated Java code.    (3.62s)
Convert byte code - optimized dex.    (3.13s)
Packaging files.    (1.10s)
Copying libraries resources    (0.04s)
    Found 1 resource files.
Signing package file (private key)    (1.62s)
ZipAlign file.    (0.38s)
Installing file to device.    Error
[  3%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[  6%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[  9%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 13%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 16%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 19%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 23%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 26%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 29%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 32%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 36%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 39%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 42%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 46%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 49%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 52%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 55%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 59%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 62%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 65%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 69%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 72%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 75%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 78%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 82%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 85%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 88%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 92%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 95%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[ 98%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
[100%] /data/local/tmp/Testaddies_RAPID_DEBUG.apk
    pkg: /data/local/tmp/Testaddies_RAPID_DEBUG.apk
Failure [INSTALL_PARSE_FAILED_MANIFEST_MALFORMED]

So, I open the example XerpChat.b4a and copy the manifest content and paste on mine. And I got the same error.

Really I don't understand what it is happening. I am new on this. This is my first application, maybe I miss some step.
This is the log when app download

B4X:
MainSyncRequestProto: lowestBkwdConvoId: 0, highestHandledServerOp: 3679322, normalSync: true
Invalid newTask was provided to startTracking.
MainSyncRequestProto: lowestBkwdConvoId: 0, highestHandledServerOp: 3679322, normalSync: true
lowestBackward conversation id 0
Usage reports 0 indexed 0 rejected 0 imm upload false
AppDataSearch: minSeqNo=54729, maxSeqNo=55154, lastCommittedSequence=54724
Usage reports 0 indexed 0 rejected 0 imm upload false
getNumBytesRead when not calculated.
>>>>>> START com.android.internal.os.RuntimeInit uid 2000 <<<<<<
CheckJNI is OFF
notifyAccountChanged
getAccountsCursor
No timezone override file found: /data/misc/zoneinfo/current/icu/icu_tzdata.dat
Sending provider changed intent: Intent { act=android.intent.action.PROVIDER_CHANGED dat=content://gmail-ls/unread/^sq_ig_i_social (has extras) }
notifyAccountChanged
getAccountsCursor
Sync complete for account: account:-579983864
register_android_hardware_Radio DONE
Calling main entry com.android.commands.pm.Pm
Failed to load assets verifier: 0
[1] com.google.android.vending.verifier.PackageVerificationReceiver.onReceive(41): Verification requested, id = 18
[70821] com.google.android.vending.verifier.ak.b(468): Exception reading file:///data/local/tmp/Testaddies_RAPID_DEBUG.apk in request id=18 java.lang.NullPointerException: Attempt to read from field 'android.content.pm.ApplicationInfo android.content.pm.PackageInfo.applicationInfo' on a null object reference
[1] com.google.android.vending.verifier.ak.c(195): Verification complete: id=18, package_name=Test.addies
[1] com.google.android.vending.verifier.ak.g(17021): Verifying id=18, result=1
Copying /data/local/tmp/Testaddies_RAPID_DEBUG.apk to base.apk
Failed to load assets verifier: 0
Failed parse during installPackageLI
android.content.pm.PackageParser$PackageParserException: /data/app/vmdl1528350286.tmp/base.apk (at Binary XML file line #14): Bad class name Test.addies.permission.C2D_MESSAGE in package Test.addies
    at android.content.pm.PackageParser.parseBaseApk(PackageParser.java:911)
    at android.content.pm.PackageParser.parseClusterPackage(PackageParser.java:809)
    at android.content.pm.PackageParser.parsePackage(PackageParser.java:773)
    at com.android.server.pm.PackageManagerService.installPackageLI(PackageManagerService.java:12659)
    at com.android.server.pm.PackageManagerService.access$3300(PackageManagerService.java:296)
    at com.android.server.pm.PackageManagerService$9.run(PackageManagerService.java:10477)
    at android.os.Handler.handleCallback(Handler.java:739)
    at android.os.Handler.dispatchMessage(Handler.java:95)
    at android.os.Looper.loop(Looper.java:234)
    at android.os.HandlerThread.run(HandlerThread.java:61)
    at com.android.server.ServiceThread.run(ServiceThread.java:46)
Starting a blocking GC Explicit
Explicit concurrent mark sweep GC freed 66506(3MB) AllocSpace objects, 7(140KB) LOS objects, 25% free, 47MB/63MB, paused 1.623ms total 159.510ms
System.exit called, status: 1
VM exiting with result code 1.
Indexing 68D514C1456BF29936D93B7F7516E2D3827CD606 from com.google.android.gm
Indexing done 68D514C1456BF29936D93B7F7516E2D3827CD606
Thread[GAThread,5,main]: No campaign data found.
vendor/qcom/proprietary/RIDL/RIDLClient/RIDLSQL.cpp:2500: GetTransState() EBADF
vendor/qcom/proprietary/RIDL/RIDLClient/MainCore.cpp:1550: Failed to get TransState, rc 9
vendor/qcom/proprietary/RIDL/RIDLClient/RIDLSQL.cpp:2500: GetTransState() EBADF
vendor/qcom/proprietary/RIDL/RIDLClient/RIDLSQL.cpp:2500: GetTransState() EBADF

Above I saw that there is a error "Bad class name", But It is the same name that I use on firebase and in b4a.

I attached the project if someone could test it.

Best Regards
 

Attachments

  • testing_firebase.zip
    9.5 KB · Views: 276

juan manuel luzuriaga

Member
Licensed User
Recently I got and answer from an Android Forum, they told me that the problem was a missing dot in the name.
So in the sentence that i got the error, I need to add before "$" a "."

B4X:
AddManifestText( <permission android:name="${applicationId}.permission.C2D_MESSAGE"
android:protectionLevel="signature"/>)

This will be in this way

B4X:
AddManifestText( <permission android:name=".${applicationId}.permission.C2D_MESSAGE"
android:protectionLevel="signature"/>)

With this change I compile and download Ok.

With this I will end this post like solved.

Thanks
 
Upvote 0

desof

Well-Known Member
Licensed User
Longtime User
Mirá la pelotudez que era!!! un punto de miercoles!
Gracias amigo me salvaste de horassssssssssssssssss
 
Upvote 0
Top