Android Question Sticky Service + Start at boot and Uninstall

Magma

Well-Known Member
Licensed User
Longtime User
Hi there,

i have created many apps with sticky services that start at boot.. but all have this problem... after uninstalling them from devices... sticky service stays at boot and works like not uninstalled before... !

What can i do - that sticky service will stop/uninstall automatically after uninstalling app... ?

Thanks
 

Magma

Well-Known Member
Licensed User
Longtime User
Not sure that I understand. The sticky service continues to work after the app was uninstalled?

Yes... :-( ...and after reboot of device continues (ofcourse i have enable the start at boot)....
 
Upvote 0

Magma

Well-Known Member
Licensed User
Longtime User
How can a service run if the app was uninstalled?

That is something i can't answer... but you can try it... check the 1st version of spyphone...

Install it... get in... exit... reboot... uninstall.. reboot.. check services that running... and tell me
 
Upvote 0

lemonisdead

Well-Known Member
Licensed User
Longtime User
Tested on Gingerbread, Jelly Bean, KitKat : uninstalling the app kills the service. It is not cached too.

Are you sure you don't have another copy already running (for example with another package name) ?
 
Upvote 0

Magma

Well-Known Member
Licensed User
Longtime User
Tested on Gingerbread, Jelly Bean, KitKat : uninstalling the app kills the service. It is not cached too.

Are you sure you don't have another copy already running (for example with another package name) ?

Sure... not running other process... or program... with the same name...
by the way this problem not having only me but other downloaded at google play too.. (more than 10 i know - and the problem is that app already downloaded from 50,000 users)

so it is a problem...

the version checked and works with these problems at android 2.3.7 and down for sure...

@lemonisdead did you install it - run it one time - reboot and then uninstall it ? and the service disappeared..?
 
Upvote 0

mangojack

Well-Known Member
Licensed User
Longtime User
Agree with lemonisdead .. Samsung Fit / Gingerbread 2.3.5 Uninstalled app and running service all gone
the app actually locked the phone up several times .. black screen / white screen
 
Upvote 0

DonManfred

Expert
Licensed User
Longtime User
Samsung Galaxy Note 3 - KitKat (4.4.2)

- Installed APK
- run it but did not enter enything. Just click on SAVE sattings and the exit app
- looked into processmanager and see service running.
- Rebooted device
- After is boots up i cannot see any service which starts at boottime. NO SERVICE RUNNING
- start app again and exit again
- NOW the service is running
- DEINSTALLED apk
- Service is gone and app is deinstalled.
- Boot device again
- App is still uninstalled and no service is running
 
Upvote 0

Magma

Well-Known Member
Licensed User
Longtime User
Guys thank you all for testing my apk...

I don't know what exactly doing - but something goes wrong... (with 1st version of spyphone)
because when... i (and many users downloaded)...

at my ZTE Racer with Android 2.3.7 (ICS) - Cyanogenmod - rooted (app no need root)

- Install APK
- Run it and do nothing like DonManFred and just save settings...
- Reboot device...
- After boot up - after 10-30 seconds service starts
-
Deinstalling apk
- Service is gone and app is deinstalled...

but.. when the app works...
- Install APK
- Run it and do settings (phone need to be set with prefix - old version) and just save settings...
- Reboot device...
- After boot up - after 10-30 seconds service starts
- work a little - receive sms / and inform the follower/spy (app do that)
-
Deinstalling apk
- Service is not gone and app is deinstalled...

Strange + many users (with old versions of android) have this problem

Again .. Thank you all
 
Upvote 0
Top