iOS Question Strange behavior of keyboard in textfield with password mode

Alex_197

Active Member
Licensed User
Hi all.
I have a very strange behavior of a soft keyboard in textfield with password mode checked. I have a project where I have a login page with2 textfields username / password.
Username is textfield with Email keyboard mode, password with default keyboard mode and password mode checked.

Registration page with registration form (textfield for a provider id with Number_Pad keyboard mode, username field with Email mode, password with default keyboard mode and password mode checked, the same text field for password confirmation and Facility text field with Number_Pad keyboard mode).

On Login page if I click on username field a keyboard appears as expected, then I move to password field - no problem.
On Registration page:

click on ProviderID field - no problem
move my focus by clicking on username field - keyboard changes to email - no problem
click on password field - grey box comes up without a keyboard itself and stays like that for 10 seconds, then keyboard appears
click on password confirmation field - grey box comes up without a keyboard itself and stays like that for 10 seconds, then keyboard appears
click on facility field - no problem

I don't understand why it takes 10 seconds for a keyboard to appear?

I've attached my small project that reproduces this issue.

I'm testing my project on iPhone 7 with iOS 14.2

Thanks.
 

Attachments

  • Login.zip
    149.8 KB · Views: 60

Alex_197

Active Member
Licensed User
Works fine here.
Restart your device and see if it persists. It sounds like an OS bug.

Tip:
- Use B4XPages.
- Try B4XPreferencesDialog.
Did some test - if I have only 1 password field among others - this problem is gone. Add second password field (for example confirm password) - problem returns.
If I put regular textfield (for example facility code with number pad keyboard mode) - problem is gone.

And it's not even in run time. This problem in designer also.
 
Upvote 0
Top