iOS Question Table Problem

Discussion in 'iOS Questions' started by tufanv, Jul 29, 2015.

  1. tufanv

    tufanv Expert Licensed User

    Hello

    for b4i, i am using table 1.11 . When i click on a cell i get an error :

    Code:
    Application_Start
    Application_Active
    <Google> 
    To get test ads on this device, call: request.testDevices = @[ @"1186180250bb52d7f409232d5159e591" ];
    innerClearAll
    375
    response success
    JobName = jobinternetkontrol, Success = 
    true
    var
    innerClearAll
    yok
    response success
    JobName = sikik, Success = 
    true
    Response from 
    server: [{"username":"feridun","score":"311"},{"username":"mevlut","score":"254"},{"username":"mevlut","score":"254"},{"username":"gizem","score":"221"},{"username":"gizot","score":"216"},{"username":"tufan","score":"117"},{"username":"Deneme","score":"100"},{"username":"Selin","score":"76"},{"username":"iclal","score":"54"},{"username":"Ggggg","score":"29"},{"username":"Hhhhh","score":"26"},{"username":"Gagss","score":"18"},{"username":"sule","score":"11"},{"username":"Duffann","score":"9"},{"username":"gizos","score":"7"},{"username":"JohnWick","score":"6"},{"username":"Mehmet","score":"4"},{"username":"Selaaams","score":"2"},{"username":"Selim","score":"2"}]
    Class (b4i_httpjob) instance released.
    Error occurred on line: 263 (Table)
    Invalid component: <B4IPanelView: 0x15ec3480; frame = (0 0; 375 623); clipsToBounds = YES; layer = <CALayer: 0x15ec3530>>
    Stack Trace: (
      CoreFoundation       <redacted> + 150
      libobjc.A.dylib      objc_exception_throw + 38
      CoreFoundation       <redacted> + 0
      Push                 -[B4ICommon getComponentBI:] + 400
      Push                 -[B4ICommon SubExists:::] + 92
      Push                 -[b4i_table _cell_click:] + 1656
      CoreFoundation       <redacted> + 68
      CoreFoundation       <redacted> + 300
      Push                 +[B4I runDynamicMethod:method:throwErrorIfMissing:args:] + 1788
      Push                 -[B4IShell runMethod:] + 496
    Push                 -[B4IShell raiseEventImpl:method:args::] + 1982
    Push                 -[B4IShellBI raiseEvent:event:params:] + 1332
    Push                 __33-[B4I raiseUIEvent:event:params:]_block_invoke + 74
    libdispatch.dylib    <redacted> + 10
    libdispatch.dylib    <redacted> + 22
    libdispatch.dylib    _dispatch_main_queue_callback_4CF + 1330
    CoreFoundation       <redacted> + 8
    CoreFoundation       <redacted> + 1512
    CoreFoundation       CFRunLoopRunSpecific + 476
    CoreFoundation       CFRunLoopRunInMode + 106
    GraphicsServices     GSEventRunModal + 136
    UIKit                UIApplicationMain + 1440
    Push                 main + 108
    libdyld.dylib        <redacted> + 2
    )
    On my table4_cellclick i dont have anything.What is the problem ?

    ty
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    It happens in the Header_Click event based on the line number.
    How are you initializing the Table instance?
     
  3. tufanv

    tufanv Expert Licensed User

    I just deleted the callback event from the table module and fixed the problem.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice