Android Question targetSdkVersion=30

Alex_197

Active Member
Licensed User
Hi all.

I have 2 questions.

1. Do I need to change my from targetSdkVersion=29 to targetSdkVersion=30 now?
2. Is there any previous Android versions such between 4 and 10 that don't support targetSdkVersion=30 ?

Because as far as I know some of my users still using phones with Android between 6 and 10 and I put the update with targetSdkVersion=30 will it work on their phones or should I keep targetSdkVersion=29 for now?

Thanks.
 

Cyan

Member
Licensed User
Hi all.

I have 2 questions.

1. Do I need to change my from targetSdkVersion=29 to targetSdkVersion=30 now?
2. Is there any previous Android versions such between 4 and 10 that don't support targetSdkVersion=30 ?

Because as far as I know some of my users still using phones with Android between 6 and 10 and I put the update with targetSdkVersion=30 will it work on their phones or should I keep targetSdkVersion=29 for now?

Thanks.

The one that controls your app's availability for previous android versions is minSdkVersion, so as long as you don't change that you're good (and also are careful about trying to use new APIs in older android versions).
 
Upvote 0

Erel

Administrator
Staff member
Licensed User
Upvote 0
Top