Android Question The Use of Net Library make close and exit the App

DOM85

Active Member
Licensed User
Hi,
I have a strange problem with the FTP library 2001-2011 (is it the right one ?).
I use it as shown int the Erel's example (https://www.b4x.com/android/forum/threads/b4x-net-library-ftp-smtp-pop-with-wait-for.84821/#content)

But i put this code in an Activity herself run by a prévious Activity.
Most clearly, i have created an Activity who runs an ftp Activity containing the Erel's example like this methode :
StartActivity ("FtpAtivity")

No complile error, installation on the phone is OK, but when i run the App i obtain immediately "App closed" without any other message. I tried to see the problem in "Debug" mode, but in this mode, just after the installation the debugging exits.

If i replace the Erel's example by the old example using "Sub FTP_UploadProgress" and "Sub FTP_UploadCompleted" this problem disappears !

If someone knows how to solve this problem, thank you.

Regards,
DOM.
Windows 10 Pro - B4A 8.50 - Net library 2001-2011
 

DOM85

Active Member
Licensed User
1 - Erel says that Net library has to work with NET 1.70.
When i renewed my B4A with V8.50 i only received a download link to B4A install. No link to B4A librares.
I looked for the new Net library 1.70, but unfortunately i did not found it yet.

2 - I agree your remark, but i see no crash, no error message, only the app close with this message "App has closed" !
And in debug mode, as i wrote before, the App exits immediately without any message.

Regards.
 

DonManfred

Expert
Licensed User
Last edited:
Top