B4J Question Update to v8.10, keep getting 'This Module is from a newer version'...

MegatenFreak

Active Member
Licensed User
Hi. Since my update to B4J 8.10, I keep getting this message every time I open any of my projects: 'This Module is from a newer version'...
I found another thread and tried changing and resaving the main module, nothing happened. My app has over 80 modules and I don't think I can go through every single one and add a space and save it, unless I'm absolutely sure it would fix the problem.
What should I do?
How does B4J determine the version of a module? and how can I update that version?
Thanks a lot in advance.
 

DonManfred

Expert
Licensed User
How does B4J determine the version of a module?
it is in the project-file
i just opened a B4J Project file (.b4j) with Notepad++
Version=7.51

B4X:
AppType=JavaFX
Build1=Default,b4j.BotDiscord
Group=Default Group
Library1=jcore
Library2=jfx
Library3=botdiscordapi
NumberOfFiles=0
NumberOfLibraries=3
NumberOfModules=0
Version=7.51
@EndOfDesignText@
#Region Project Attributes
    #MainFormWidth: 600
    #MainFormHeight: 600
#End Region
[..]
 
Upvote 0

MegatenFreak

Active Member
Licensed User
Oh my God... stupid stupid stupid Internet Download Manager... Instead of downloading B4J from the link, it gave me an older download with the same file name😖😫🤬
I was wondering how come I got version 8.10 when the site says the latest is 8.9!! (someone should have told me that 8.10 would be 9.0!! I'm such an idiot!!)
 
Upvote 0
Top