Android Question Updating an existing app made with Ecllipse (keystore issue)

Discussion in 'Android Questions' started by Dan Harding, Jun 23, 2015.

  1. Dan Harding

    Dan Harding Member Licensed User

    I have an application that I rewrote using B4a, but would like to post it on Google as an update to an existing app. I have seen some posts about not being able to do that directly in B4a unless that is where it was started (at least that the way I think it was meaning).

    But it mentioned about compiling the app without signing it and then signing it afterward. For someone confused by that process (me), could someone provide a little more detail how to do that? I know I have the right keyStore and password (using the private sign key in B4a) but when I try to compile in release mode I get this error:

    Signing package file (private key) Error

    jarsigner: Certificate chain not found for: b4a. b4a must reference a valid KeyStore key entry containing a private key and corresponding public key certificate chain.

    So I found related entries elsewhere on this forum. I just a little lost as to specifically what to do.

    Thanks,
     
  2. Erel

    Erel Administrator Staff Member Licensed User

  3. Dan Harding

    Dan Harding Member Licensed User

    I received the same error as the user in the post:

    Signing package file (private key) Error

    jarsigner error: java.security.SignatureException: private key algorithm is not compatible with signature algorithm

    So, I will pursue creating an unsigned apk and signing it manually
     
  4. Dan Harding

    Dan Harding Member Licensed User

    Following the instructions created a "aligned" version of the apk file for me. No errors that I could see. However, when I uploaded to a web page and used that URL to try to install the apk file on an Android phone, after download, I just see the message: Unfortunately, the Package installer has stopped.

    Unless someone has some further ideas, I guess I am going instruct users to delete old app and install new one.
     
  5. Dan Harding

    Dan Harding Member Licensed User

    I tried using instructions which included using B4ABuilder to manually build the apk without signing and then using jarsigner (Must be JDK 6, not 7 or 8) and was just getting a message: App Not installed.

    I discovered that my versionCode variable was set to 3 on my new B4a app and the most recent version on Google play had that set to 5. (I was comparing AndroidManifest.xml files) After changing that to 6 and going through the manual process one more time, it successfully updated over my existing app created from Ecllipse. Yeah!!
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice