Android Question V5.00 hangs trying to load after upgrade from 4.0

Discussion in 'Android Questions' started by qle, Jun 10, 2015.

  1. qle

    qle Member Licensed User

    Hi,
    I upgraded from 4.30 to the new v5.0 today, install went ok, without error.
    But trying to load, i get the new see though B4A splash screen, and the win7 progress wheel.. but that it!

    I have reinstalled 4.30 and this is running ok.. (pheww!)

    Os: Win7 32bit
    I have tried an uninstall (via add/remove) and removing the 'Program Fles\Anywhere Software' app folder to install fresh, but same thing, just sits at the new splash screen...

    Lee
     
  2. Erel

    Erel Administrator Staff Member Licensed User

  3. qle

    qle Member Licensed User

    Yes i have .Net Framework 4.5.2 installed. I have just run a reinstall (repair).
    but still the same...
    have left it for 5 mins now, just sitting on the B4A splash..
    i have to end task it...

    [Edit]
    I did a full uninstall of .Net Framework, and B4A (via control panel add/remove)
    I removed folder \Program Files\Anywhere Software and \AppData\Roaming\Anywhere Software I also went though registry to remove any references i could find.
    I then installed the .Net framework 4.5.2, and B4A 5.0, and launched at end of install.. but same thing..

    Back to 4.30, works fine..

    [Edit]
    Tried again, installing v5.0 over the top of the working 4.30, same problem, but then i tried using the IDE ..\B4A.EXE -log option, and it fired up!!! but if i remove the -log option it hangs at the splash screen again!
    While it seems to work if i leave the -log option in, not sure i can trust the stability of the IDE.

    .Net version: 4.0.30319.34209
    B4XClassifer created
    B4XErrorTagger created
    Gui: 1007
    *** no reuse ***
    Gui: 824
    Gui: 54

    Lee.
     
    Last edited: Jun 11, 2015
  4. Erel

    Erel Administrator Staff Member Licensed User

    This is indeed strange. All the -log option does is to redirect the console output streams to a file.

    You can add the -log to a shortcut icon and then run it this way.
     
  5. qle

    qle Member Licensed User

    Well it seems stable enough with the -log option.. but take it out and it wont load.. odd indeed!
    i do have 3 monitors, not sure that should effect it though..

    Will see how i go...
     
  6. qle

    qle Member Licensed User

    resolved with 5.02
     
    Erel likes this.
  7. mirekk36

    mirekk36 Member Licensed User

    I have downloaded and installed 5.20 ... and now I have the same situation. B4A IDE don't answer for a very long while, ... after that I can write code but if only I will save something to disc or do F5 (compile) it hangs ... hangs, hangs ... about 1-2 minutes - then go

    All it is after installing ver 5.20 ... If I reinstal 5.02 it don't help anymore :(
     
  8. mirekk36

    mirekk36 Member Licensed User

    I have found some solution ... It turned out, that if I delete my "b4xV5.ini" from "C:\Users\admin\AppData\Roaming\Anywhere Software\Basic4android", there B4A IDE starts , write/read files normally, and new inifile was created.
     
    DonManfred likes this.
  9. eps

    eps Well-Known Member Licensed User

    Cheers, thanks for this! I had to do the same after I'd been stuck on 4.3 for a while :) Rmoved the ini file and then all is well - all the way up to 6.0 now!

    Cheers!!
     
    DonManfred likes this.
Loading...