Android Question Warning-APK target SDK 23 or higher (solved)

f0raster0

Well-Known Member
Licensed User
I got this warning:
Upgrade to new permission model
Warning:

Users that currently have APK with version code 16, which targets SDK 22 or lower, will be eligible to upgrade to this APK. However, once users upgrade to this APK, they will be unable to upgrade to APKs that target SDK 22 or lower.

Tip:

If this is an intended change, then ensure that all future updates for the users that upgrade to this APK target SDK 23 or higher.

B4X:
<uses-sdk android:minSdkVersion="22" android:targetSdkVersion="26"/>

I'd like to ask for you understanding about the warning and why I should use SDK23
when I use
B4X:
<uses-sdk android:minSdkVersion="23" android:targetSdkVersion="26"/>

i got the same warning, maybe:

it is just a warning to remain me what my app always should be 23+

thanks
 
Last edited:
Top