Android Question webviewextras executejavascript fails to work in lollipop

Discussion in 'Android Questions' started by rthyoung26, Apr 30, 2015.

  1. rthyoung26

    rthyoung26 Member Licensed User

    I have had a program working fine for a couple of years but parts of the code does not seem to work under lollipop 5.0. The following code has always worked in previous android versions but does not seem to execute in lollipop

    Javascript="B4A.CallSub('WebView1_SaveWebPage', true, '"&WebView1.Url&"', document.documentElement.outerHTML)"
    WebViewExtras1.executeJavascript(WebView1, Javascript)

    Anyone any suggestions? The WebView1_SaveWebPage function does not get called but always worked before android 5.0

    DISREGARD - issue is now closed 30/04/2015
     
    Last edited: Apr 30, 2015
  2. warwound

    warwound Expert Licensed User

    Does this work on Kitkat?
    The major changes to the WebView were introduced in Kitkat so i'd expect problems with Kitkat too.

    Do you see anything in the unfiltered log - anything relevant?
     
  3. rthyoung26

    rthyoung26 Member Licensed User

    Works fine in kitkat. Haven't looked at any logs yet. No errors get reported, it just doesn't appear to execute this code any more.
     
  4. rthyoung26

    rthyoung26 Member Licensed User

    Close the thread. No longer an issue.
     
  5. DonManfred

    DonManfred Expert Licensed User

    You should have posted the solution for any user which will look at this thread in future.
     
    warwound likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice