Bug? Win7 auto hide Taskbar not showing while in B4A

Discussion in 'Bugs & wishlist' started by JohnK, Oct 13, 2018.

  1. JohnK

    JohnK Active Member Licensed User

    I am currently running B4A v8.3 on a Win7 Prof box, with the taskbar set to autohide.

    In other programs, when I move my mouse to the bottom of the screen, the Taskbar auto displays/appears.

    However, when I am in B4A,this does not occur. To make it appear I either have to press Ctr-Esc hot-key, or Alt-Tab to another app, and move the mouse into position.

    Is it just me?
     
  2. Erel

    Erel Administrator Staff Member Licensed User

    The IDE is a regular WPF application. It doesn't do anything special with the taskbar.
     
  3. JohnK

    JohnK Active Member Licensed User

    I'm not saying it does do anything different. However, the above is how it behaves, which is not 100% correct. I have other WPF developed apps, and they do not behave in this manner. It may be a specific WPF bug, but either way, its not an optimal behavior.

    It does not need to do anything specific with the taskbar, however, if it consumes the windows events in the region of the taskbar activation area, that may stop the taskbar activation area from responding. I do notice that there is a specific B4A window, in the area that is normally the taskbar activation area. It may be consuming these mouse events and therefore not making them available to the system.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice