B4R Question WROOM 02 Problems When Uploading

R_906

Member
Licensed User
Hi:

I have a WROOM 02 connected to a USB To UART chip. After grounding IO0, it works fine when flashing the Espressif AT commands(using their flashing tools) so I do know it can be flashed and my connections are correct. The AT commands then work perfectly.

When I ground IO0 and try to upload using B4R and the Generic ESP8266 selection, I get upload errors. I even tried the ESP12E selection. The baud rate to the wroom2 is fixed at 115200 by the converter chip.

Any help would be greatly appreciated.

Thanks, Rob
 

R_906

Member
Licensed User
Hi Erel:

I have not tried that. I am able to upload, using B4R, to the Wemos D1 Mini. I used the HTTP client sample on the D1 Mini and it works perfectly. Typically when flashing the WROOM I have to pull IO0 low for it to work. With the D1 Mini it somehow does that automatically.

I hope this info is helpful.

Rob

Edit:

I just tried uploading a sketch from Arduino IDE and I receive the same type of upload errors.
 
Last edited:
Upvote 0
Top