B4J Question B4J Error: A JNI error has occurred, please check your installation and try again

giggetto71

Active Member
Licensed User
Longtime User
Hi,
after changing the PC I have re-installed from scratch B4J (before everything was working fine even if I was running an older B4J version and possibly an older JDK) . With B4J 8.9 and JDK 11, I am facing a strange issue trying to run a B4J app on the Raspberry Pi.
Attached a super simple program which is causing the issue. Basically when I try to run it on the RPI I get:
"A JNI error has occurred, please check your installation and try again". On the RPI it also throws:

"Exception in thread "main" ....has been compiled with ta more recent version of the Java Runtime (class version 53.0) this version of the Java Runtime only recognizes class file versions up to 52.0"

Does that mean I have to update the Java runtime on the RPI? I currently have 1.8.0_65-b17 (running java -version).
thanks
 

Attachments

  • TestRPI.zip
    791 bytes · Views: 79

giggetto71

Active Member
Licensed User
Longtime User
got it sorted. I have used Java 8 instead of OpenJDK 11 and after that I was able to run B4j code on the RPI.
 
Upvote 0
Top