Basic4ppc with wine on Linux ?

Discussion in 'Chit Chat' started by agolan, Aug 14, 2008.

  1. agolan

    agolan New Member

    :sign0085: I Use Linux all day long and don't feel like rebooting into Widows when I want to do some development for WM.

    There is of course the possibility to have a Windows on top of VMware and then use it for the IDE, but it's like using a big truck to carry the grocery shopping home :( .

    Another option would be to run it under "wine" which is a windows environment simulation, I use it to run a few windows programs (among them Explorer for testing purposes).
    So I would like to know if someone tried to use the desktop Basic4ppc IDE on top of wine.

    Thanks,
    Alon.
     
  2. agraham

    agraham Expert Licensed User

    It won't run under Wine as that is a Win32 emulator and Basic4ppc is a .NET app. It might have run under Mono but I ran the Mono Migration Analyser on it and it fails on P/Invokes to Win32 dlls so I guess it's back to VMware :(
     
  3. agolan

    agolan New Member

    I was about to try,
    Thank you for sparing my time :sign0188:.

    :sign0137: I will have to see if I can find any other development whatever for WM/x that can run under Linux.
     
  4. steedj

    steedj Member Licensed User

    Hi,

    I installed Basic4ppc on wine. It's not already perfect. I' m looking for other's experiences.

    Before installing B4PPC you need to install dotnetfk2 and VC++2005 runtime. To do so follow the next steps in a terminal window (I'm working on ubuntu 8.04):

    wget http://kegel.com/wine/winetricks
    sudo apt-get install cabextract
    sh winetricks corefonts dotnet20
    sh winetricks vcrun2005sp1

    After that install B4PPC in wine.

    You can then run B4PPC and run your programs. The only problem (quite big) is that I can't see the source code!!

    Can you try and tell the result?
     
  5. LineCutter

    LineCutter Active Member Licensed User

  6. joel2009

    joel2009 Member Licensed User

    Hate to dig up a year old thread but......

    I ran the commands for ubuntu you provided and installed it all. Unfortunately basic4ppcdesktop still does not run (it installs but them after trying to run from wine program menu it attempts to open and then just nothing happens...) any advise?

    I thought maybe i was needing to direct basic4ppc to its dependant files??

    No idea really im new to the linux word but thought i would give it a try due to the promise of win32 emulation.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice