Spanish Dudas sobre versiones de android y una duda sobre hacer fotos con camara.

matmax

Member
Licensed User
Hola tengo una primera duda desde hace mucho tiempo y aun no se. Si yo hago una aplicación en b4a con la versión sdk 27 que creo que corresponde al android 8.1, esta aplicación funcionaria con una versión superior de android, es decir android 9, 10,...?

La segunda duda es que tengo hecha una aplicación con la librería cameraview 1.01. A la hora de hacer funcionar la opción de cámara de fotos, en algunos móviles funciona y en otros no (por ejemplo probado en un móvil xiaomi y sale el mensaje de cámara no disponible), ¿A que se debe el fallo en los móviles que no funcionan, por la librería, por la cámara del propio móvil?. Si alguien ha tenido algún problema con una apk con cámara y los móviles xiaomi, que lo comente. Muchísimas gracias.
 
Last edited:

José J. Aguilar

Well-Known Member
Licensed User
Si yo hago una aplicación en b4a con la versión sdk 27 que creo que corresponde al android 8.1, esta aplicación funcionaria con una versión superior de android, es decir android 9, 10,...?
Hola Matmax:

Este post podría despejarte esta primera duda. Si tienes problemas en entender algo del post o del inglés, no dudes en preguntar


La segunda duda es que tengo hecha una aplicación con la librería cameraview 1.01
Supongo que te refieres a esta librería de DonManfred. La verdad que no la conozco, y viendo el hilo de github no me queda muy claro, pero parece que soporta Camera1 y Camera2.
Si ves los hilos de esas librerías en el foro, verás:
Camera1: No encuentro exactamente la librería, sino CameraEX que la extiende, y el hilo indica que se puede usar a partir de Android 2.3+
Camera2: Camera2 library is based on the newer Camera API introduced in Android 5 (API 21). It is therefore supported by Android 5+ devices.

Es decir, la primera podrías usarla en todas las versiones de Android más antiguas (a partir de 2.3) y Camera2 solo a partir de Android 5.

En fin, no sé si te ha quedado muy claro, si nos puedes dar más detalles del error que te da, le echamos un ojo

saludos,
 

matmax

Member
Licensed User
Hola. Gracias Jose . Sobre la primera pregunta que hago y después de haber leído el post con mi bajo nivel de ingles, la versión de la compilación debe de estar entre la versión mínima de android y la máxima, y entiendo que la máxima debe de ser la misma versión del dispositivo en el cual se ejecutara la aplicación. Ejemplo, una aplicación creada con la API 27 o android 8.1 no funcionaria en un móvil con android 10.. ¿Es correcto?

Y sobre la segunda pregunta, modificare la aplicación y usare la librería camera2 que parece que es mas reciente y funciona a partir de la 5.
 

José J. Aguilar

Well-Known Member
Licensed User
Hola de nuevo matmax, a ver si no me lío explicando, por favor, si cometo algún error que alguien me corrija.

minSdkVersion: tu aplicación solo funcionará en dispositivos con esa versión de Android o superior.
targetSdkVersion: esto indica qué funcionalidades soporta la app que has desarrollado. La app funcionará en versiones anteriores, pero no soportará todas las funcionalidades de tu APP. Por ejemplo, si ahora usas Camera2 que funciona a partir de Android 5, tu app funcionará en un dispositivo con android 4, pero no soportará la cámara. Es más, al instalar te indicará algo como: "Esta app está desarrollada para una versión superior de su S.O."

Q: Will my app run on Android 4.0 if targetSdkVersion is set to 8.0? Funcionará my app en Android 4.0 is targeSdkVersion es 8.0?
A: Yes. Es decir, si creas la aplicación con targetSdkVersion 8.1 funcionará en Android 10. Pero si pones minSdkVersion 8.1, no funcionará en Android 7.
 

matmax

Member
Licensed User
Hola. Aun no modifique el código para usar la librería camera 2. Vale, una cosa es la versión de la aplicación con respecto al dispositivo y otra la versión de android que usan las librerías por ejemplo como es en este caso la cámara de fotos/vídeo.
Entonces funcionaria a partir de la versión mínima hacia adelante y con respecto a la cámara, funcionara la aplicación pero por la librería camera 2 no funcionara por debajo de la versión 5. Gracias por responderme. Un saludo.
 
Top