Spanish Error de autenticación en firebase luego de actualizar

desof

Well-Known Member
Licensed User
Longtime User
Hola amigos,

Tengo una app en marcha hace ya mas de 2 años y ahora que actualice B4A a 8.30 y el SDK Managger All
En mi Manifest utilizo
<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="26"/>

El path Java esta actualizado C:\Program Files\Java\jdk1.8.0_181\bin\javac.exe

El path Android Tbn!! D:\Android\android-sdk\platforms\android-27\android.jar

TEngo la version 1.02 de FirebaseAuth (no logro conseguir la mas nueva creo 1.05)

He actualizado el archivo google-services.json

****************************************
Y la misma me compila pero se me cierra al iniciar y no llego ni a poder depurar para detectar el error por que no llega ni a Activity_Create
*************************************

y he visto que hay que usar CreateResourceFromFile(Macro, FirebaseAuth.FirebaseAuth)

Pero no entiendo si hay que simplemente colocar esa linea en el Manifest o hacer algo más ?

Muy apreciable su ayuda
 

rscheel

Well-Known Member
Licensed User
Longtime User
Hola amigos,

Tengo una app en marcha hace ya mas de 2 años y ahora que actualice B4A a 8.30 y el SDK Managger All
En mi Manifest utilizo
<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="26"/>

El path Java esta actualizado C:\Program Files\Java\jdk1.8.0_181\bin\javac.exe

El path Android Tbn!! D:\Android\android-sdk\platforms\android-27\android.jar

TEngo la version 1.02 de FirebaseAuth (no logro conseguir la mas nueva creo 1.05)

He actualizado el archivo google-services.json

****************************************
Y la misma me compila pero se me cierra al iniciar y no llego ni a poder depurar para detectar el error por que no llega ni a Activity_Create
*************************************

y he visto que hay que usar CreateResourceFromFile(Macro, FirebaseAuth.FirebaseAuth)

Pero no entiendo si hay que simplemente colocar esa linea en el Manifest o hacer algo más ?

Muy apreciable su ayuda

Quizás el problema este en el servicio si estas usando android:targetSdkVersion="26" deberás realizar modificaciones en el servicio, tal como indica erel en la documentación de B4A a 8.30
 

desof

Well-Known Member
Licensed User
Longtime User
disculpa pero no te entiendo! He leido que se recomienda utilizar el 26 a partir de agosto.
Pero no he advertido que hable de modificaciones ...
Alguna otra segerencia ?
 

musaso

Active Member
Licensed User
Prueba a instalar estas actualizaciones AQUI (FirebaseAnalytics v1.02 and FirebaseAuth v1.05 are attached.)
 

GeoT

Active Member
Licensed User
Hola:
Me descargué el archivo rar que dice musaso. Una de las librerías que contiene es la versión 1.04 de FirebaseAuth. Esta librería tiene problemas con la antigua firebase-auth-16.0.1 que hay en C:\Android\extras\b4a_remote\com\google\firebase\firebase-auth.
Pero parece que funciona con la nueva firebase-auth-16.0.2.

Sigue las instrucciones de Erel en Firebase Notifications & Firebase Auth Issues.

Los que utilizamos B4 v8.30 creo que debemos actualizar los componentes de Android desde el menú superior de B4A: Herramientas/SDK Manager.

Saludos.
 

desof

Well-Known Member
Licensed User
Longtime User
Hola:
Me descargué el archivo rar que dice musaso. Una de las librerías que contiene es la versión 1.04 de FirebaseAuth. Esta librería tiene problemas con la antigua firebase-auth-16.0.1 que hay en C:\Android\extras\b4a_remote\com\google\firebase\firebase-auth.
Pero parece que funciona con la nueva firebase-auth-16.0.2.

Sigue las instrucciones de Erel en Firebase Notifications & Firebase Auth Issues.

Los que utilizamos B4 v8.30 creo que debemos actualizar los componentes de Android desde el menú superior de B4A: Herramientas/SDK Manager.

Saludos.

YA NO SE QUE HACER estoy a punto de tirar la toalla borre y desintale el SDK y el B4a instalé todo de nuevo y me asegure qie este todo actualizado como indica EREL pero nada me funciona en cuanto a firebase.
a mi me sigue mostrando la libreria 1.04 .
De donde descargo la que decis ? firebase-auth 16.0.2?
 

GeoT

Active Member
Licensed User
Tranquilo Desof.

Desde el menú superior de B4A: Herramientas/SDK Manager.
 

GeoT

Active Member
Licensed User
Es un error de Erel. Si, no está en ese rar la FirebaseAuth 1.05, sinó la 1.04.
 

desof

Well-Known Member
Licensed User
Longtime User
m
Es un error de Erel. Si, no está en ese rar la FirebaseAuth 1.05, sinó la 1.04.
mira la iamgen por favor . en librerias me aparece 1.04 y en el SDK Manager 1602
 

Attachments

  • temp.jpg
    temp.jpg
    157.6 KB · Views: 231

GeoT

Active Member
Licensed User
Si. Yo estoy igual.
Solamente llegué hasta ese punto.
Almenos ahora no hace crack.
Pero el código no me muestra que me logueé. Sino

B4X:
--------- beginning of main
--------- beginning of system
*** Service (starter) Create ***
** Service (starter) Start **
** Activity (main) Create, isFirst = true **
FirebaseAuth initialized
** Activity (main) Resume **
onAuthStateChanged: com.google.firebase.auth.internal.zzj@e5c1569
SignInWithGoogle called
** Activity (main) Pause, UserClosed = false **
sending message to waiting queue (OnActivityResult)
running waiting messages (1)
SignInWithGoogle.ResultArrived
ResultArrived Error: Status{statusCode=DEVELOPER_ERROR, resolution=null}, null
** Activity (main) Resume **
onAuthStateChanged: com.google.firebase.auth.internal.zzj@e5c1569
** Activity (main) Pause, UserClosed = false **
** Activity (main) Resume **
** Activity (main) Pause, UserClosed = true **

¿Y a tí?
 
Last edited:

desof

Well-Known Member
Licensed User
Longtime User
vos tenes la 1.05 ? me la podes compartir . Ami me compila pero hace crak!!!!!
 

GeoT

Active Member
Licensed User
Vale, ya me va. Me faltaba la Clave de Firma Privada. ¿Conoces cómo va?

La librería FirebaseAuth 1.05 no existe. Es la 1.04.

Te adjunto un archivo con el proyecto. Cambiale la extensión a rar.
 

Attachments

  • FirebaseAuth.txt
    5.6 KB · Views: 217

GeoT

Active Member
Licensed User
En ese archivo debes ponerle tu Clave de Firma Privada. Y tu nombre de paquete en la Configuración de Compilación (Ctrl + B).
 
Last edited:

GeoT

Active Member
Licensed User
Ponle uno por defecto. No puse código allí.
No me debaja ponerle más cosas por tamaño.
 

desof

Well-Known Member
Licensed User
Longtime User
estees el crahs!!

B4X:
egisto conectado a:  motorola Moto G (4)
--------- beginning of main
*** Service (starter) Create ***
FirebaseAuth initialized
starter_service_create (java line: 160)
java.lang.NullPointerException: Attempt to invoke virtual method 'void com.google.firebase.auth.FirebaseAuth.addAuthStateListener(com.google.firebase.auth.FirebaseAuth$AuthStateListener)' on a null object reference
    at anywheresoftware.b4a.objects.FirebaseAuthWrapper.Initialize(FirebaseAuthWrapper.java:57)
    at sancrisapp.desof.starter._service_create(starter.java:160)
    at java.lang.reflect.Method.invoke(Native Method)
    at anywheresoftware.b4a.BA.raiseEvent2(BA.java:191)
    at anywheresoftware.b4a.BA.raiseEvent(BA.java:171)
    at sancrisapp.desof.starter.onCreate(starter.java:56)
    at android.app.ActivityThread.handleCreateService(ActivityThread.java:3183)
    at android.app.ActivityThread.-wrap5(ActivityThread.java)
    at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1563)
    at android.os.Handler.dispatchMessage(Handler.java:102)
    at android.os.Looper.loop(Looper.java:154)
    at android.app.ActivityThread.main(ActivityThread.java:6123)
    at java.lang.reflect.Method.invoke(Native Method)
    at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:867)
    at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:757)
--------- beginning of crash
 

GeoT

Active Member
Licensed User
¿Tu nombre de paquete coincide en Firebase y en la Configuración de Compilación (Ctrl + B)?
¿Creaste una Clave de Firma Privada después de eso en B4A?
 

desof

Well-Known Member
Licensed User
Longtime User
SI MI APLICACION YA FUUNCIONABA HASTA QUE ACTUALICE TODO. CONOZCO EL PROCESO POR QUE TENGO VARIAS QUE UTILIZAN AUTENTICACION,
.
AHORA ME URGE ACTUALIZAR UNO Y LE TENDRE QUE QUITAR LA VALIDACION !
POR ESTE PUTO FIREBASE QUE ME LLEVA HACIENDO PERDER HORAS !!!!!!
 

GeoT

Active Member
Licensed User
Perdona. En el ejemplo de esa página, para tu versión de B4A es mejor sustituir el código viejo de Firebase en el Manifest Editor por:

B4X:
CreateResourceFromFile(Macro, FirebaseAnalytics.GooglePlayBase)
CreateResourceFromFile(Macro, FirebaseAnalytics.Firebase)
CreateResourceFromFile(Macro, FirebaseAuth.FirebaseAuth)

Y el targetSdkVersion al 26.
 
Top