Android Question Graph ?

walterf25

Expert
Licensed User
The same result
This B4AGraphView.jar problem
HI, did you copy the three files in your additional library folder?

Walter
 

walterf25

Expert
Licensed User
This would have added to the list
Try changing your android.jar file to a higher version, maybe 21.

Thanks,
Walter
 

walterf25

Expert
Licensed User

Attachments

walterf25

Expert
Licensed User
Not work!
A similar jar substitute it?
I'm not sure what's going on, i know the library works as it should. The last thing would be for you to zip your entire project and post it so that i can take a look at what exactly is going on.

Walter
 

walterf25

Expert
Licensed User
You're not wrong it is the only way
Even Initialize not work
GraphView_001.zip → GraphView.zip.001
GraphView_002.zip → GraphView.zip.002
There is something wrong with your zip files, they seem to be corrupted, can you zip them again and upload them, for some reason they download but after extracting them the folders disappear.
 

walterf25

Expert
Licensed User
Ok, so two things!

First of all, you are missing one parameter in your Initialization line.
you have this:
B4X:
Dim g As graph
Dim l As LineSeries
g.Initialize("My Graph")
The initialization requires two parameters, the EventName and a boolean indicating whether you are using dates or not. It should be like this:
B4X:
Dim g As graph
Dim l As LineSeries
g.Initialize("My Graph", false)
And the second thing is that you need to have the AppCompat library selected as well, if you don't have it please download it from here. http://www.b4x.com/android/forum/attachments/appcompat_v1_10-zip.30896/
All this is specified in my first post here, it is in big bold blue letters. http://www.b4x.com/android/forum/threads/graphview-library.34995/

Hope this resolves your issues.
 

kuosda

Active Member
Licensed User
Basically you can use them, but I have a problem
Amplitude PP (Y axis) can not set minimum and maximum spacing
If ID:walterf25 see it. can you help me answer it
 

Attachments

walterf25

Expert
Licensed User
Basically you can use them, but I have a problem
Amplitude PP (Y axis) can not set minimum and maximum spacing
If ID:walterf25 see it. can you help me answer it
The Y axis are scaled automatically, i don't think the original library allows us to manually change the scale.

Walter
 

kuosda

Active Member
Licensed User
If the x-axis is datetime will result y-axis range sometime big or small
, I tried Eclipse reversal translation but failed worship, Can you please help me add y axis maximum and minimum settings or source code to me and my own modify
I'm very much obliged to you
 

walterf25

Expert
Licensed User
If the x-axis is datetime will result y-axis range sometime big or small
, I tried Eclipse reversal translation but failed worship, Can you please help me add y axis maximum and minimum settings or source code to me and my own modify
I'm very much obliged to you
Can you post an image so I can see what you're talking about?

Thanks,
Walter
 
Top