1. *** New version of B4J is available ***
    B4J v7.8
    Dismiss Notice

B4J Question jrdc2 not working

Discussion in 'B4J Questions' started by John Decowski, Jul 17, 2019.

  1. John Decowski

    John Decowski Member Licensed User

    im having a real problem getting jrdc2 to work. i have absolutely no problem using rdc original. im getting the error code below. I think my problem lies with setup and build of this app. I checked and double check my config file which is just about the same as rdc1. I place a copy of connector jar file in "additional_libraries" folder as instructed. I defined it in the code. I'm running the code in debug mode but also tried it in release. Im using mysql server. #AdditionalJar: mysql-connector-java-5.1.27-bin.

    thanks in advance @Erel
     
    Last edited: Jul 17, 2019
  2. John Decowski

    John Decowski Member Licensed User

    well in case anyone runs into this... i just figured out my problem... I did not have the correct version connector file defined and downloaded. I defined mysql-connector-java-5.1.27-bin (because i wasn't paying attention to the age of the library), and needed -connector-java-8.0.16. ALSO: in new version of MYSQL the driver class changed from: DriverClass=com.mysql.jdbc.Driver to: DriverClass=com.mysql.cj.jdbc.Driver in config file.

    Also noticed that username for db is case sensitive in jrdc2 and may not of been in rdc1.
    Well hopefully this information will help someone. but not sure why it worked fine in rdc1?
     
    Last edited: Jul 17, 2019
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice