Android Question Manifest for VR Application

Blueforcer

Active Member
Licensed User
I want to install an B4A App on my new Oculus Quest VR Headset.
If i start the App via IDE (adb) the Quest run the app without problems.
But even if i install the app via Sideload i cannot find it in the Applist. I think i have to change something in the manifest to detect the app as an VR app.

https://developer.oculus.com/distribute/latest/concepts/publish-mobile-manifest/
(i think the section below "Application Manifest Specification" is necessary)


Can someone tell me, according to the given link, how i have to set my manifest?

p.s i have sideloaded some other VR apps like QuakeGVR
https://github.com/DrBeef/QuakeGVR/releases
And this app is displayed in the list for unknown sources. but not mine
 
Last edited:

Blueforcer

Active Member
Licensed User
B4X:
AddManifestText(
<uses-sdk android:minSdkVersion="23" android:targetSdkVersion="26"/>
<supports-screens android:largeScreens="true"
    android:normalScreens="true"
    android:smallScreens="true"
    android:anyDensity="true"/>)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
SetApplicationAttribute(android:value, "vr_only")
 

DonManfred

Expert
Licensed User
have you checked this library?
https://www.b4x.com/android/forum/threads/google-vr.75628/#content

from theire website about manifest:

Application Manifest Specification
Your AndroidManifest.xml file must meet the specifications outlined on the Android Manifest Settings page.

  • The package name should not be left as default or copy/pasted from another app. It must not be shared with any other Oculus Store app.
  • The installLocation must be set to auto.
  • The versionCode must be greater than the value used in a previous build of this app.
  • The android:debuggable value must be false. Your app must be a release version, not a debug version.
  • android:minSdkVersion, android:targetSdkVersion, and android:compileSdkVersion must be set appropriately. API versions greater the minimums specified prevent users from installing your app. For previously released app, use caution when changing the minSdkVersion as you may break compatibility for users on older versions of Android. For apps that target both Quest and Go/Gear with the same APK. minSDKVersion should be lower of the values, but the target and compile versions must align with the higher Quest values.
    Following are the accepted values for minSdkVersion, targetSdkVersion and compileSdkVersion by device:

    Device minSdkVersion targetSdkVersion compileSdkVersion
    Go/Gear 21 21+ 21+
    Quest 23 25+ 26+
  • You must have android.intent.category.INFO, instead of android.internet.category.LAUNCHER. Your app must only appear in Oculus Home. It must not appear in the phone’s launcher.
  • The excludeFromRecents value be set to true.
 

Blueforcer

Active Member
Licensed User
I dont know if i need the Lib, because my app only opens the android settings menu wich is normaly hidden. And this works if i start the app via adb.

i now changed my manifest to


B4X:
AddManifestText(
<uses-sdk android:minSdkVersion="23" android:targetSdkVersion="26"/>
<supports-screens android:largeScreens="true"
    android:normalScreens="true"
    android:smallScreens="true"
    android:anyDensity="true"/>)
SetApplicationAttribute(android:icon, "@drawable/icon")
SetApplicationAttribute(android:label, "$LABEL$")
SetApplicationAttribute(android:value, "vr_only")
SetApplicationAttribute(android:launchMode,"singleTask")
SetApplicationAttribute(android:excludeFromRecents,"true")
'End of default text.
AddActivityText(Main,
<intent-filter>
   <action android:name="android.intent.action.MAIN" />
   <category android:name="android.intent.category.INFO" />
</intent-filter>)
but it will not shown up. did i missed something else?
 
Top